View Single Post
  #25  
Old 02-01-2014, 02:30 AM
dz1976biker dz1976biker is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2014
Age: 38
Posts: 2
Gender: Male
Vehicle: 2002 dodge ram 1500 quad-cab
Trim Level: slt
Color: grey
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
dz1976biker is on a distinguished road
Default

Wow seem like everyones having the same problem of having no heat on the driver side and only some heat on the passenger side. Well check this out. I've got NO heat on my passenger side and very little heat on the drivers side? And that very little heat only works on the lowest control settings. If i turn the heater up it only ends up blowing cold air. I'll turn it off, wait a few seconds and turn it on and it'll be warm again for only a few second. Again only on the drivers side. Mines a 2002 Ram 1500 4.7. I bought it a year ago with 94000 on it. Since i"ve had it I put a new motor (the old one ended up with probs cause some ******* decided to put a shitty weld in the radiator, but thats another story), and replaced the rad, thermostat, waterpump, and the place i bought it from put a new heater core in it. I did't replace any of these parts myself so I don't know the quality of how they were installed. Sounds like my problems are the same as everyone elses accept I have no heat on the passenger side and minimal heat on the drivers side. Where shall i start to fix this? Anyone have a course of action on where to start and to move on from there?
Reply With Quote