View Single Post
  #1  
Old 07-09-2014, 10:02 AM
deanmax deanmax is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2014
Location: La Center, Wa.
Posts: 1
Gender: Male
Vehicle: 1998 Dodge Ram
Color: green
Engine: 1996-1998 359ci (5.9L) Cummins 12-valve Diesel I6 215hp 440lb/ft(manual), 180hp 420lb/ft(auto)
Rep Power: 0
Rep:10
deanmax is on a distinguished road
Default transmission pressure sensor and govenor continue going out

I m having problems with the pressure sensor and govenor. an example is i can replace them and pull a loaded trailer to San Jose Ca. and make a return trip loaded and they are out by the time it gets back to Portland Ore. I'm not the driver but i do know it's not taken out of overdrive and it's driven 70 plus miles per hour. I've tried to keep up with these drivers in my motorhome but i like to live.
The owner of the equipment has me second guessing myself that these trucks are having the same issues that it's something I'm not doing right.
So here I am asking for some input.
These trucks are used for all holidays from 4th of July to Christmas so from hauling fire works to hauling pumkins and christmas trees. And tractors and excaviators pulling at least 10,000 lbs or more per trip.
Is it something I'm over looking thanks
also these trucks are 2500 and 3500 dodge ram diesel and double axle trailers which when they leave the lights and trailer brakes work but when they come back the wiring is gone on the trailers and no trailer brakes when ever i dont follow and thats when most problems occure.
Reply With Quote
Sponsored links