Thread: Hid Problems??
View Single Post
  #1  
Old 02-18-2010, 01:10 AM
pcasso87's Avatar
pcasso87 pcasso87 is offline
Dodge Ram Forum Senior Member
 
Join Date: Oct 2009
Location: San Antonio, TX
Posts: 81
Gender: Male
Vehicle: 2500 & 1500 laramies
Trim Level: Laramie 4x4
Color: Stone White / Silver
Engine: 2011-20?? 409ci (6.7L) Cummins Turbo Diesel 350hp 800lb/ft
Rep Power: 0
Rep:10
pcasso87 is on a distinguished road
Default Hid Problems??

i decided to install some 5000k hids for my headlights and fogs. Since the first night a friend who sells hids installed them the problems began... First my right one failed and he replaced the ballast saying it was faulty at no cost. About 4 days went by and it dies on me again, this time i was in a trip so i stopped at a shop and bought another ballast so i could make the trip back home because i had to drive at night. The ballast i had installed at the other shop was another brand different from the one my friend sells, it worked perfect and got me back home so i decided to leave it in there. The next night it decides not to work again it will flicker as if it was going to turn on and then dies completely , i dont understand it seems as if the right headlight loves to kill my ballasts!!! Any ideas what might be causing this??? Its weird because its the only one with that problem it all ready went through two sets of different brand ballasts!!! and i just saw some condensation in the right headlight as well could it be possessed by a headlight demon??

No but seriously what could be causing this??? Its only the right headlight that seems to have the problems.
__________________
l 2012 Ram 2500 Laramie Long Horn 4X4 l 2009 Ram 1500 Laramie 4x4 l 2011 Audi A4 l Scion FR-S l
Reply With Quote
Sponsored links