View Single Post
  #1  
Old 03-01-2010, 05:22 PM
Zekery360 Zekery360 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jun 2009
Location: St. Cloud, MN
Age: 24
Posts: 392
Gender: Male
Vehicle: 2002 Dodge Ram
Trim Level: Sport
Color: Bright Red
Engine: 2002-2003 360ci (5.9L) Magnum V8 245hp 335lb/ft
Rep Power: 0
Rep:11
Zekery360 is on a distinguished road
Default Vehicle Speed Sensor Issues (Dead Speedo)

Recently, after washing my truck to look beautiful, my speedometer went dead. I also have a code P0500, VSS Malfunction. So, I have a couple questions to assist in my diagnosis. 1) Is there more then one sensor that could cause the issue? My Ford buddy (I know, apples to oranges, but bear with me) says he has 2 sensors that affect his speedo. So, is it just my one sensor, or is there another in the diff or something? and 2) The diagnostic flowchart I got off of Alldata in my school shows a bunch of tests on the PCM. I am wondering if it is ok to run tests without taking the Superchips tune off, or if I should return my truck to stock first. I have looked for any fuses, couldn't find one that even sounded like it protected the VSS, the sensor is not shorted in itself, and I couldn't get continuity from the connector side back. I also could not find any frayed wires or anything that could have gotten wet and shorted out. Everything was still loomed up really nice just like from the factory. Any help would be greatly appreciated.

Thanks guys!
Reply With Quote
Sponsored links