View Single Post
  #1  
Old 07-26-2010, 04:53 PM
79JON 79JON is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2010
Age: 31
Posts: 7
Gender: Male
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:10
79JON is on a distinguished road
Default Oil pressure problems on my 01 1500 Ram 5.2

I recently bought a used 01 Ram 1500 with the 5.2 318 The truck ran fine with no problems with no oil pressure problems what so ever. Last weekend, I went ahead and changed the oil and I also added some Engine Restorer to the oil because the truck has 121K on it. Well.. since doing that it ran fine the first few days of driving it but then I started noticing after it warms up, when I come to a stop my oil pressure drops to zero and check guages light pops on.. then the oil pressure pops back up. Also after warming up the engine is starting to tap when it goes up in RPMS.. that is what is scaring me. Ive been reading and my guess is the engine restorer loosened up some sludge and now the screen is getting blocked preventing the oil to lubricate the rest of the motor. Does that sound right? My question is, can I remove the oil pan without lifting the engine? Its a 2WD ext cab truck. If I can do that.. I think I need to open her up and clean out the sludge and go ahead and replace the oil pump while im in there. Also, my oil pressure just less than 40psi when driving on the highway and sitting in traffic. Is that ok? id say its in the 30-35 psi range. I just wanted to make sure.

Thanks,
Jon
Reply With Quote
Sponsored links