View Single Post
  #37  
Old 08-11-2010, 01:53 AM
ken99 ken99 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2010
Location: Montana
Posts: 107
Gender: Male
Vehicle: 2010 Ram 1500 Crew 4x4
Trim Level: SLT
Color: Austin Tan Pearl
Engine: 2009-2010 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:26
ken99 is on a distinguished road
Default

Quote:
Originally Posted by mricig View Post
Hi Ken,

I am in the same boat as you with only one connector for the trailer brake module. Would you mind posting some pictures of your connections to the harness?

Thanks in advance,

Mike
Quote:
Originally Posted by Vic Howard View Post
Just wondering if it is working ok. I ordered one from my local Dodge dealer and it came in but they advised that there has been problems with it and Dodge is working on a fix. If you are not having any problems (they suggest it affects a computer setting possibly) then I am going to try it on my 2010 Ram 1500 Quadcab.
Guys - My notes are summarized in the attached PDF file. My dealer didn't indicate this modification would cause problems, they simply insisted it could not be done. When I informed the parts dept that I had been able to make the controller work in my truck, they admitted Chrysler has issued TSB stating an adapter kit to retrofit the "B" harness would be available in late 2010. Until then I guess the "official" word is the factory controller cannot be made to work with these trucks.

Ken
Attached Files
File Type: pdf 2010_dodge_itbm_install.pdf (218.8 KB, 874 views)

Last edited by ken99; 08-11-2010 at 02:00 AM.
Reply With Quote