View Single Post
  #1  
Old 10-07-2010, 10:53 PM
jerm jerm is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2010
Posts: 3
Gender: Male
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
jerm is on a distinguished road
Question Need a little help...

Hopefully I am not posting a question that has already been answered. I saw similiar posts but not exact...

I am having problems with my 05 ram 1500. Awhile back, my wife was driving my truck... I say this because I am using her descriptions of what went wrong... Anyway, she was driving home and noticed that the A/C wasn't cooling. The air was still blowing fine and there was no change in performance, just no cold air. As she pulled into the drive the truck died and wouldn't start again. By the time I got home from work I had to jump start it to attempt to figure out what was wrong. Well, I got it started and after a few minutes the truck died again. So I jumped it again.. same result. So I guessed it was an electrical problem (bad battery and/or possibly a bad alternator). I charged the battery and tried again, this time to discover new problems and it died after sitting in the drive after a day and a half.

I have had the alternator rebuilt (bearings were bad) and have replaced the battery. I have also unsuccessfully tried to find a draw on the battery. The truck runs fine and during short test drives it performs fine. However, upon start-up the voltage gauge only goes about 1/4 of the way over. After running for a few minutes it drops all the way back down to no voltage and the check gages light comes on. And of course, my A/C still isn't cooling...

Any advice or help would be greatly appreciated. Also, if you know a rough price estimate of repair that would be great also... Money is tight to say the least, as I am a new dad. If at all possible or reasonable I intend to troubleshoot and/or repair it myself. Hopefully, I am just overlooking something simple.
Reply With Quote
Sponsored links