Thread: What did I do?
View Single Post
  #1  
Old 11-06-2010, 06:38 PM
timmytard timmytard is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2010
Location: Maple Ridge, B.C. Canada
Age: 39
Posts: 15
Gender: Male
Vehicle: 1998 dodge ram 2500
Color: dented white
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
timmytard is on a distinguished road
Default What did I do?

Hi yall, I just got a used 2500 360 5.9ltr.
The other day I noticed a burning smell, I popped the hood & there seemed to be a tiny bit of antifreeze spray on the block.
I loosened the rad cap, which seemed to be cool to the touch.
There was kind of a popping sound, when I went to tighten it back up a few seconds later it was super hot. & I seen the "DO NOT OPEN HOT" written on the cap.

Got back in started her up, within minutes the temp gauge was in the red.
There were bells & buzzers, flashing lights, I cranked the heat to try to cool it a bit but it just blew cold.

I was in rush hour. I kept putting it into neutral & coasting as much as I could which would bring it out of the red & the disco room would turn off.
But as soon as I put it back in drive the temp gauge would go back up in the red and the the party room would start again.

I stopped about half way home, @ a toys'r'us and used a hose & sprayed the rad for 1/2 hour, gave some one a jump start.

I went to a friends house on my way home, let it sit for about four hours.
It was completely cool when I left for home, on the drive home the temp gauge went to just over half way, but no heat would blow out, just cold.

Did I blow the thermostat? Or did I do something worse?

If any one knows of a video tutorial of how to change the thermostat, if that's the problem would be great.

Thanks
TT
Reply With Quote
Sponsored links