View Single Post
  #1  
Old 11-27-2010, 07:14 PM
Quiet Lunatic's Avatar
Quiet Lunatic Quiet Lunatic is offline
Dodge Ram Forum - Dodge Truck Forum - Dodge Ram Club
 
Join Date: Sep 2008
Location: Purgatory
Posts: 2,169
Gender: Male
Vehicle: SRT-10
Color: Red
Engine: 2004-2006 505ci (8.3L) Viper V10 510hp 535lb/ft
Rep Power: 7
Rep:434
Quiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enoughQuiet Lunatic will become famous soon enough
Default Blend door motor won't stop going

I was told that the plastic coupling that connects the blend door and the motor may be broken, since I have no regulation of my hot and cold. Followed the direction to take it off, and sure enough the little plastic coupling is broken. Bought a new one at the dealer for the out rageous price of $15.00. Now for the weird part. I try and install it, and in trying to align it up, I started my truck, had the temp dial set to full hot. The motor keeps turning and turning. Mine has three electrical connection points in the plug. Was told, when the motor sences the "spike" as the door is fully in one direction, the motor is suppose to stop. I tried stopping it with my fingers and even a pair of pliers. It's still runs. I think this is what broke the plastic couplingin the first place. I don't really want to install it and see it happen again, and have to spend another $15.00 on a new one. What else could be wrong, in why the motor won't stop?
Reply With Quote
Sponsored links