View Single Post
  #28  
Old 12-28-2010, 01:07 PM
parrothead's Avatar
parrothead parrothead is offline
Dodge Ram Forum Newcomer
 
Join Date: Dec 2010
Age: 58
Posts: 13
Gender: Male
Vehicle: 2010 Dodge Ram
Trim Level: SLT
Color: Bright Metallic Silver
Engine: 2009-2010 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:13
parrothead is on a distinguished road
Default

Quote:
Originally Posted by Black05 View Post
I have an 05 4x4 SLT and I have the same complaints about the trans everything else is on point. I really noticed it the other day when hauling some cars to/from WV 1500lb up trip, 2500lb car home after a trade. Power was not an issue the truck didn't even feel like it had a load behind it, however sometimes it felt like it was in too high a gear and would not downshift unless the accelerator was press considerably. When pressed in this fashion once it downshifted it wanted to go. This was prevalent even in TOW/HAUL mode although less noticeable. I don't know though maybe just a little quirk I'll get used to, until I get my DSP
I used to have a 04 S/B S/C HEMI and hated the TOW/HAUL program because it seemed like you almost had to floor it to get it to kick down.By then you've lost 30mph the trans drops 2 gears which sends the tach screaming south and scares the crap out of ya.Then I went to Ala to pick up a car.On the way back to Texas I20 was pretty light so I used the cruise set on about 75MPH along with TOW/HAUL on.To my surprise things went very smooth.The truck would drop one gear when needed then go back at the top of the hill.For some reason it was much better when used with cruise control.I haven't towed with my 010 yet but I expect about the same thing.
BTW I made the same trip last year in my 03 Ford F-150 4.6 (towing a race car) and the requirements were simple...To maintain 70MPH keep the gas on the floor and stop at every gas station LOLOL!
Reply With Quote