View Single Post
  #1  
Old 04-12-2011, 04:54 PM
ehlersa ehlersa is offline
Dodge Ram Forum Newcomer
 
Join Date: Apr 2011
Location: Lanesville, IN
Age: 35
Posts: 2
Gender: Male
Vehicle: 2004 Dodge Durango
Trim Level: Limited
Color: Red
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
ehlersa is on a distinguished road
Default MDS engine into non-MDS car issues

Hey guys, I'm new here........hope you don't mind me posting a Durango question on a Ram Forum. I bought a 2004 Durango 5.7L (non MDS) with a blown motor (had a snapped rod and 2 holes in the block) with the intent to fix the engine. I bought an engine with MDS from a guy on Craigslist.......I think it was from a Ram (timing cover and oil pan were different). Anyway, I switched over all of my sensors including crank position, cam position, knock sensors, timing cover, oil pan, etc. I also removed the MDS sensors and plugged the holes with the dummy plugs that were in my blown motor (just a plastic cap basically). Well I got it all hooked up and started the engine and it runs like crap. It will barely run at idle, is blowing white smoke out the exhaust, and has a little bit of a tick.....sounds like a lifter tick......but I've read that these 5.7 Hemis are known for having a tick and no associated problems. I believe the guy that it was a good engine. When I have it up around 3-4000 rpms it is running decent, but not perfect. Anything under 2000 and it is extremely loping and at idle barely runs at all. The white smoke is making me think I may possibly have water in my gas........but I also read on another forum that white smoke could also be a sign of a very very very rich condition and that the fuel is getting burned up in the cat. converters and putting out the white smoke. Usually I've only seen more of a black smoke with a rich condition.....but the exhaust does have somewhat of a fuel odor to it. I checked the oil and it's not white so there seems to be no coolant leaking into the oil. I haven't checked compression yet to verify it's not a blown head gasket, but the engine only had 60k miles so I wouldn't think that's not it. I have a question about the MDS. I read RamTech's article on this so I'm somewhat familiar with how it works. The part I'm not sure of is.........do the MDS sensors shut down the lifters by allowing oil to flow to them or by blocking oil from flowing to them? My dummy plugs are allowing oil to flow to the lifters. I was told by 2 dodge mechanics that I would be fine by putting the MDS engine into my vehicle.....they said that it would run on all 8 as if the different cam and lifters weren't there. Is that correct? From the write-up, I read that high pressure oil will disconnect a pin in the lifter causing it to not open the valves. That makes is sound like it will shut down by getting oil to it. I'm used to old engines where the lifters needed oil......this sounds like the opposite. Am I missing something here? Any info or ideas you guys can give me would be greatly appreciated. Thanks. Anthony.
Reply With Quote
Sponsored links