View Single Post
  #1  
Old 04-18-2011, 01:34 PM
xopt1js's Avatar
xopt1js xopt1js is offline
Dodge Ram Forum Senior Member
 
Join Date: May 2010
Location: Pickering, ON
Age: 33
Posts: 332
Gender: Male
Vehicle: 2010 Dodge Ram QC 4x4
Trim Level: Laramie
Color: Briliant Black Crystal Pearl/Light Greystone
Rep Power: 0
Rep:39
xopt1js is on a distinguished road
Default Question for SRT-10 rim owners......Help needed with rubbing

OK, so I did a test fitment with my new wheels a few weeks back and found that there was major rubbing. No problem........ordered a set of 1/4" spacers.

Got the spacers last week and installed the rims/tires on the weekend. Got a small problem though............seems as though the drivers side front MIGHT be rubbing while the passenger side has enough clearance and no rubbing.

Now I am not 100% sure that there is rubbing. How do you guys tell? Can you feel it? Hear it? I am pretty sure I rub a little at full lock which is no big deal, but am concerned about rubbing during normal driving.

Seems weird that the 2 sides seem to be different but maybe it's just me being paranoid. I have not gotten an alignment done yet so maybe that will fix it? Perhaps I need to level the truck?

Anyone else encounter this issue? My setup is below so anyone with similar specs please provide your experiences. Thanks in advance.


2010 1500 Laramie
Stock Suspension (No lift or level)
1/4" spacers
20" SRT-10 Replicas
305-50-20 Goodyear Eagle GT2
No alignment done yet
__________________
Mopar Chrome Side Steps, 3.92's, Moonroof, Nav/Alpine, Tow Package, Under Rail Bedliner, Extang Trifecta, BT Catch Can, 20% Tint, Mopar All Weather Mats, Tinted Window Deflectors, Mopar Chrome Bug Deflector, Afe Stage II CAI w/ Pre Filter, Black MGP Caliper Covers, Black Stubby Antenna, DeeZee Tailgate Assist, Mopar Power Tailgate Lock, 20" Chrome SRT-10 Replica's with 33" Terra Grapplers

Last edited by xopt1js; 04-18-2011 at 01:46 PM.
Reply With Quote
Sponsored links