Thread: Front defrost
View Single Post
  #1  
Old 08-18-2011, 12:19 PM
LUBINATOR's Avatar
LUBINATOR LUBINATOR is offline
Richie

 
Join Date: Mar 2011
Location: North NJ
Age: 62
Posts: 183
Gender: Male
Vehicle: 2009 Ram 1500 SLT Quad Cab
Trim Level: SLT
Color: Inferno Red
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:12
LUBINATOR is on a distinguished road
Default Front defrost

A question to our resident experts.

4.7 2009 SLT 1500 QC manual climate controls

My problem is that depending on humidity and temp, of course, I can run my defrost on max fan, there is air coming out of all the defrost ports I believe, including those that should defrost the front side windows.

It takes forever to clear off the condensation, on the outside of the windows. The wipers will clear it away, but it comes right back on windshield and side windows.

The AC seems to be working well enough when I use it, and even if I run fresh air intake, no recirc, from the vents, it still does not clear up.

If I raise the heat up it will clear the windshield and side windows faster, but this is summer, I should not need to heat the air. The dealer checked the system and did not find anything.

Any ideas?

Thanks in advance

Richie
__________________
RAM 1500 SLT QC 2009 INFERNO RED, ARE Lift Lid ,Spray on Bed Liner, K&N Drop In, Pioneer DEH P8400UB, Alpine Amp, Mopar Kicker sets in all doors and dash, 2 Polk 10" Subs, Polk AMP, SteelCraft Nerf Bars, Mopar Fog Lights, CalTrend Seat Covers, WeatherTech Front Mats, Putco SS Fender Liners, SuperBumper SS Hitch Step/Impact Absorber, Onki Aegis SS Center Guard, PIAA 2100 driving lights
Reply With Quote
Sponsored links