View Single Post
  #1  
Old 10-01-2011, 10:31 AM
JRodMTB's Avatar
JRodMTB JRodMTB is offline
Dodge Ram Forum Junior Member
 
Join Date: Feb 2011
Location: Warren, MI
Age: 35
Posts: 49
Gender: Male
Vehicle: 2014 RAM 1500
Trim Level: Outdoorsman
Color: White
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 0
Rep:10
JRodMTB is on a distinguished road
Question Truck Pulling after Bilstein Install

I had my 5100's installed by a reputable shop that a lot of people at work use a couple weeks ago. Unfortunately the shop's alignment rack couldn't accommodate the 20" wheels that we have on our truck so in a pinch I ended up taking the truck to a local Belle Tire to have an alignment done.

This past week I had it back to BT for the 3rd time because the truck is pulling hard to the left. I understand roads have crown but if I straighten out the wheel, the truck will shift lanes in about 5 seconds unless I'm in the very right lane. The last time I was in the shop, dude told me that the truck is as close to factory spec as possible (I have all 3 alignment sheets) and that if I was still having issues that it was most likely due to the lift.

I've rotated tires, made sure that my tires are all the same pressure (35psi) and have done a quick "hand" check on the brakes to make sure wasn't locking up and causing the pull. I'm rolling on 275 Cooper LTZ's and have the shocks set at the 2" lift (2nd ring from top).

Has anyone else experienced this with the Bilstein's or do you guys think my alignment is still off? Thanks!
Reply With Quote
Sponsored links