View Single Post
  #48  
Old 10-18-2011, 08:00 PM
srpa's Avatar
srpa srpa is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2011
Location: CT
Posts: 5
Gender: Male
Vehicle: 2011 Dodge Ram 1500 Laramie
Trim Level: Laramie
Color: Deep Water Blue
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
srpa is on a distinguished road
Default

Hi all,

This is my first post on this forum. I bought a 2011 Ram 1500 two months ago and found this forum by accident. I'm glad I did; the information on this forum has been invaluable - thank you to all the members!

Anyway, just wanted to say that I noticed the infamous torque converter noise when I first picked up my truck. After racking up 1000 miles, the noise got worse. I called the dealership in my area and they initially said it was the MDS. I went for a ride with the trans tech, and he noticed it right away and agreed it was the torque converter. Long story short, dealer had my truck two days. Torque converter was pulled and was found to have "failed." Not sure how or in what way, but they replaced the torque converter and now my truck shifts great with no noise, just as it should have from the factory.

To those who think they have this problem: be persistent. The shop foreman at my dealer said they never heard of this problem, and that mine was the first that they had seen. I think many people are accepting the noise as normal behavior, even though it is being caused by a defective part.

Again, thank you all for the help. I love my truck again!
Reply With Quote