View Single Post
  #6  
Old 12-18-2011, 01:23 PM
Warlock III Warlock III is online now
Is tired of the BS too
 
Join Date: Aug 2010
Location: Earth...DUH!
Posts: 7,805
Gender: Male
Vehicle: 1995 Ram 1500
Trim Level: Cloaking
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 11
Rep:1776
Warlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant future
Send a message via AIM to Warlock III Send a message via Yahoo to Warlock III
Default

Quote:
Originally Posted by MADDOG View Post
Agreed ^^^^ If it was working before, then the coolant issue and the heater core need to be looked at.

If the HVAC functions of defrost, vent, heat, floor, mix don't work, then it's the HVAC blend door, which is a common issue.
The thermal relay on the passenger's side floor board up under the glove box-towards the center is another thing worth checking in the hopes of not having to do the blend door which as MD said is a common cause.

I'd turn wrenches on the water pump to repair the obvious problem and see if a proper coolant level alleviates the problem...if not you've got a couple of good leads to follow.

By the way... The fan is threaded to the water pump. Pull one of the 13mm bolts on the pulley behind it and stick a screw-driver in the hole to keep it from spinning when you turn the large nut COUNTER-CLOCKWISE. (That was a preemptive post)

Last edited by Warlock III; 12-18-2011 at 01:29 PM.
Reply With Quote