View Single Post
  #6  
Old 08-07-2009, 08:44 AM
Excoastie's Avatar
Excoastie Excoastie is offline
Dodge Ram Forum Senior Member!

 
Join Date: Aug 2008
Location: Bossier City, LA
Age: 42
Posts: 3,445
Gender: Male
Vehicle: 2014 VW Jetta GLI
Color: Metalic Black
Rep Power: 10
Rep:1358
Excoastie has much to be proud ofExcoastie has much to be proud ofExcoastie has much to be proud ofExcoastie has much to be proud ofExcoastie has much to be proud ofExcoastie has much to be proud ofExcoastie has much to be proud ofExcoastie has much to be proud ofExcoastie has much to be proud ofExcoastie has much to be proud of
Default

I had a K&N Typhoon on my wife's Magnum. I had what often sounded like a "pinging" sound coming from under the hood. It was mostly during acceleration, but it also happened sometimes at idle.

Came to the conclusion that it was the warmer air from the engine bay, mixing with the cooler air that it was sucking in, (it seems that the seals around the heat shield were not very good, if they worked at all).

I had a friend of mine help me to better close up the open spaces around the heat shield. We used a bit of sheet metal, some quick welds, and a bit of weather stripping. The decreased the pinging, but didn't completely cure it.

Not sure if you've got the same problem, but that's what happened with me. I've had no trouble out of the AEM brute force I've got on my Ram...

good luck

Exco
__________________
Oracle Interior LEDs, EGR Vent Visors, Ram eyes, Husky Liner Splash Guards, R/T Badges Front and Rear, LED Light Bar, Stubby Radio Antenna, Custom Shift Knob, ARE LS II bed cover, Bed Rug, Flowmaster 50 series HD, SilverStar Ultra low beams, K&N drop in filter, MOPAR sill guards, Smitty Built nerf bars, 24% tint on the front.
Bill
Reply With Quote