View Single Post
  #5  
Old 03-15-2012, 05:25 PM
toddbweaver toddbweaver is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2010
Location: Hinesburg Vermot
Age: 52
Posts: 9
Gender: Male
Vehicle: 2012 Dodge Ram Power Wagon
Trim Level: SLT
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
toddbweaver is on a distinguished road
Default My 2012 Power Wagon transmission broke with 1000miles

Purchased it new about 4 weeks ago. It's been in the shop now for over a week. Started clunking while shifting from 2nd to 1st gear, and 1st to 2nd gear. Couple days later I got in and low and behold the check engine light was on. I called the dealer to make an appointment. The couldn't get me in until 2 days later. I also noticed that after the check engine light came on the torque converter was not engaging. The day I was to bring to the dealer I backed out of the driveway to go to work and it would only go into 4th gear. So I got turned around and luckily I only had 2 lights and a stop sign and about 30 miles to the dealer. Traveled around 40-45 with only 4th gear...not 1, 2, 3, 5, or 6 just 4th. They have now torn out the transmission ordered numerous parts and still not fixed. I've called Dodge Customer Service and demanded a new truck, new transmission, lifetime engine drivetrain warranty. My understanding from the dealer now is they have ordered a whole new transmision. I will post more when I get more information. I've had 4 dodges and no problems until this one. Maybe someone is telling me I should have kept my 09 that was perfect.

Todd
__________________
2012 Dodge Ram Power Wagon 4x4 Crew Cab, black
Reply With Quote