View Single Post
  #8  
Old 10-18-2012, 06:48 PM
ramvan2500's Avatar
ramvan2500 ramvan2500 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Apr 2011
Location: Florida USA
Posts: 1,903
Gender: Male
Vehicle: 1995 Dodge Ram B2500 Van
Trim Level: SLT - 2500
Color: Deep Molten Pearl Coat, Silver, Grey
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 4
Rep:128
ramvan2500 will become famous soon enoughramvan2500 will become famous soon enough
Default

Quote:
Originally Posted by mrau92me View Post
Thanks for the info, ramvan. I'll try adjusting the front band first. Note: I had the transmission fluid changed by a shop but it didn't help.
My apology to everyone for posting and then disappearing, but I thought I subscribed to this thread, in addition to my other vehicles developing more-urgent issues (daughter's Passat water pump went belly up).

I'll also add that the previous owners (friends of mine) had the transmission rebuilt in '07 at 105k miles and really only drove it after that point to occasionally tow their ski boat a few miles during the summers. I bought it cheap coupla months ago with 117k on the clock after their crazy dog chewed up the transmission wire harness trying to get a cat (I don't think the dog could have done any damage to cause the slipping). $20 and some soldering later, I fired it up. They said there were no issues prior to that, other than the fuel gauge . My theory is that they didn't know it was slipping after they got it rebuilt because they were moving it just a few feet and letting it idle (warming it up) as they hooked their boat up.
Well if you get stuck, have questions. Just ask. Happy to help
Reply With Quote