View Single Post
  #3  
Old 11-08-2012, 04:30 AM
RamSport1500's Avatar
RamSport1500 RamSport1500 is offline
Dodge Ram Forum Junior Member
 
Join Date: Apr 2012
Location: Maine
Age: 30
Posts: 32
Gender: Male
Vehicle: 2006 Dodge Ram
Trim Level: Sport
Color: Slate
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
RamSport1500 is on a distinguished road
Default

I have a 06 Ram Sport 1500 5.7 Quad cab... my right low beam went... Did somee research through here a lot of guys are having problems with that same issue. Its the TIPM (Total Intergrated Power Module) Dodge basically wired everything through it... When it starts going it does that. Commonly its the right passanger low beam that goes.... Had my personal Mechanic check the truck confirmed it. I dont rust a Dodge mechanic... they like sales men they say almost anything amd change you hundreds to fix it and still be wrong. Once I confirmed it was the TIPM I had to go to a Dodge dealer cause appearently you have to get the part from Dodge and Dodge as my mechanic told me has a monoply on the flash codes so outside sources cant get it. Unless you have a buddy that can hook you up at a Dodge dealer its going to be pricey fix... I spent just under $700 to fix it... and at the time i had only had the truck months from date of purchase. After it was replaced I noticed my trucks features working like the radio staying on with Ignition off after they key is out until you open the door. Im now having issues with my Instrument cluster... Tach reading 500 RPM at 70 mph on the highway and 0 at a idle... The dodge dealer originally said the lights and the cluster were the cause of the TIPM but the replacement only fixed the head light and some of the features... my cluster is still all jacked upand now they are saying its a seperate issue but want to run more "test" to confirm it...
Reply With Quote