View Single Post
  #4  
Old 11-08-2012, 08:48 AM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 43
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

Quote:
Originally Posted by RamSport1500 View Post
I have a 06 Ram Sport 1500 5.7 Quad cab... my right low beam went... Did somee research through here a lot of guys are having problems with that same issue. Its the TIPM (Total Intergrated Power Module) Dodge basically wired everything through it... When it starts going it does that. Commonly its the right passanger low beam that goes.... Had my personal Mechanic check the truck confirmed it. I dont rust a Dodge mechanic... they like sales men they say almost anything amd change you hundreds to fix it and still be wrong. Once I confirmed it was the TIPM I had to go to a Dodge dealer cause appearently you have to get the part from Dodge and Dodge as my mechanic told me has a monoply on the flash codes so outside sources cant get it. Unless you have a buddy that can hook you up at a Dodge dealer its going to be pricey fix... I spent just under $700 to fix it... and at the time i had only had the truck months from date of purchase. After it was replaced I noticed my trucks features working like the radio staying on with Ignition off after they key is out until you open the door. Im now having issues with my Instrument cluster... Tach reading 500 RPM at 70 mph on the highway and 0 at a idle... The dodge dealer originally said the lights and the cluster were the cause of the TIPM but the replacement only fixed the head light and some of the features... my cluster is still all jacked upand now they are saying its a seperate issue but want to run more "test" to confirm it...

I'd love to offer some advice and opinion or two, but I'm a Dodge mechanic and obviously untrustworthy. BTW, we don't have the "monopoly" on flashes. Properly equipped independent shops can do them as well. Best of luck to you with your problem.
Reply With Quote