View Single Post
  #1  
Old 01-10-2013, 05:34 PM
MDReptile MDReptile is offline
Dodge Ram Forum Junior Member
 
Join Date: Jun 2012
Age: 26
Posts: 38
Gender: Male
Vehicle: 98 1500 5.9L QuadCab Sport RWD
Rep Power: 0
Rep:10
MDReptile is on a distinguished road
Default Why its my 98 1500 losing oil pressure at hard stop, or really tight turn?

Lately, in my 98 1500 quad cab 5.9 sport, I'll brake hard, and today even semi hard (maybe I'm paranoid lol), as I'm coming to a stop, and at like 8mph the oil pressure kicks completely to zero, on the stock oil pressure gauge. The light saying check gauges comes on. This started only about a week ago, but the trucks rather late for an oil change is one thing, already passed 4k, maybe 5k...(overall had 115k'ish) And I'm waiting for a check to show up and get it changed asap, but I'm worried about driving to work until that happens, at least a week, while this oil pressure thing its going in, incase the engine takes damage in the mean time.

Plus, I do not notice any change whatsoever in the engine sound, no vibration at all (out of the ordinary anyway), which leads me to believe some sensor or whatever might be giving a false reading... I read online that these use an electronic pressure deal, which could maybe possibly have something to do with it?

What's your thoughts guys? Old oil clogging some strange part up? Electrical malfunction? Really losing all my oil pressure suddenly at quick stops?

Trucks in decent shape - I don't push it too hard, and have not had really any problems with it since purchase a year and a half or so ago, at 106k miles.
Reply With Quote
Sponsored links