View Single Post
  #1  
Old 01-13-2013, 05:41 AM
aoaner's Avatar
aoaner aoaner is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2013
Location: Germany
Age: 44
Posts: 6
Gender: Male
Vehicle: 2011 RAM 1500
Trim Level: Crew Cab Laramie
Color: mineral grey
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
aoaner is on a distinguished road
Default Help! Heated drivers seat isnt working

Hi community,
i got an issue with my 2011 RAM...the heat elements of my drivers seat wont work anymore...so when im pushing the switch for it both led are on but wont warm up...and switch shut up after a few seconds.
So i readed some repair manuals and they said to measure the resistance of both heat elements....the resistance of the cushion element is ways to high, its about 30 Ohms and should be 4.8 to 5.8 Ohms. Guess that it is gone....
But im a bit unsure about that, cause i also measured also the voltage is coming up on both heat elements when the switch is enabled (before it shuts down again after a few seconds) and that has been only 4 Volts on each heat element. Maybe they are wired serial and that is normal, but im pretty unsure.
You guys have to know im from germany, and Dodge doesnt sale this car officially in germany. So its imported by a dealer and theres only limited warranty on it.
But on the other hand, the car is only 13 month now...way to early for a heated seat out of order already....so im pretty sad about that.
I really love my RAM and i want to get that fixed again...
Maybe there is someone around who is experienced with that stuff and can give me some advice what to do....feel a bit helpless for now...cause there is not really a support over here in germany...
Thanks in advance,
Roland
Reply With Quote
Sponsored links