DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, & Solutions - Maintenance & Repair > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Powertrain > 5.2L V8 Specific Topics
Register Advertising Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read


Latest Vendor News
Addictive Desert Designs!
Bayou Goat Mounts

Thread Tools
Old 02-15-2013, 11:33 PM
Lonestar Lonestar is offline
Dodge Ram Forum Newcomer
Join Date: Feb 2013
Location: Alberta, Canada
Posts: 1
Gender: Male
Vehicle: 2011 Ram 1500 Sport 4x4
Trim Level: Sport
Color: White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Lonestar is on a distinguished road
Default 1997 1500 4x4 5.2L low/rough idle and stalling

Hey everyone, new to the dodge scene but loving it so far. My daily is a 2011 1500 CC 5.7 4x4 and thankfully its been flawless since I bought it.

My other toy is a 1997 1500 4x4 with a 5.2/ 5-speed. Its got 212,000km's and is a fairly solid truck all around. Since I picked it up I've noticed it had a low/rough idle and will stall occasionally when decelerating or coming to a stop.

I've searched around for typical causes for this and have so far come up with nothing to solve it. I've done the following repairs/diagnosis so far:

-resealed the plenum gasket and cleaned tb with the hughes kit. runs smoother, but no change for low idle.
-checked vacuum lines for leaks (except where they enter the cab through the firewall) couldn't find any issues
-tested for faulty idle speed motor with new solenoid, no difference
-tested voltage, signal and ground on tps and map sensors, both checked out to the best of my knowledge.
-changed out intake charge temp sensor, no change
-new plugs, wires, cap/rotor

KOEO self test came up with these codes:


Dunno what else to do, and like I said these are the first dodge trucks I've ever owned so I'm still learning the mopar tricks and basics.

Any input to help me getting this truck running smoother would be great. I'd rather beat on my 2nd gen since it already has a 6 inch lift and 37's. My 4th gen is too pretty to bag or take mudding.

Thanks in advance
Reply With Quote
Sponsored links
Old 03-05-2013, 12:44 PM
paintengr's Avatar
paintengr paintengr is offline
Dodge Ram Forum Newcomer
Join Date: Mar 2013
Location: Garden City, MI
Age: 58
Posts: 26
Gender: Male
Vehicle: 97 Ram 1500
Trim Level: sport
Color: elect blue
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
paintengr is on a distinguished road

I had the same issue, replaced IAC thought that would do, but no trolled forums and reread pintle adjust, it took me two time in readjustment but seems to be OK now. I hope that helps.
Paintengr' old school bracket racer, robot, yea it's got a wedge !
Reply With Quote


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:26 PM.

= Copyright a Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2015, vBulletin Solutions, Inc.