DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Electrical


Notices

Electrical 3rd Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 03-13-2013, 08:33 PM
IndyGreg IndyGreg is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2013
Location: Indianapolis
Posts: 4
Gender: Male
Vehicle: 2002 Dodge Ram SLT Quad 2wd
Trim Level: SLT
Color: Silver
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
IndyGreg is on a distinguished road
Default Cruise comes on then turns off.

Brand new to me truck. When I first push cruise button it will light for a second or 2 then go out. i can do it again and it comes on but goes out even faster for 2 or 3 times then won't light up at all.

It will not stay on long enough for me to set cruise and sheck if it works. I believe the problem is in the switch on steering wheel. is there a way to verify this or possible take apart and clean contact?

Thanks for your feedback.
Reply With Quote
Sponsored links
  #2  
Old 03-17-2013, 08:50 PM
IndyGreg IndyGreg is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2013
Location: Indianapolis
Posts: 4
Gender: Male
Vehicle: 2002 Dodge Ram SLT Quad 2wd
Trim Level: SLT
Color: Silver
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
IndyGreg is on a distinguished road
Default Still not working

So if I start motor and put foot on brake cruise light will stay on for 30 seconds plus, as soon as I release brake within a second or two cruise light goes off.

So I thought it must be the brake light switch and it is a cheap enough part.
replaced it with the same results.

If it were the wheel speed sensors would it not stay lit while sitting still? could it be the PCM?
Reply With Quote
  #3  
Old 03-19-2013, 07:27 AM
tjbiker031's Avatar
tjbiker031 tjbiker031 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2011
Location: Bradenton, FL
Age: 30
Posts: 307
Gender: Male
Vehicle: 2002 Dodge Ram
Trim Level: SLT - Quad Cab
Color: Graphite Metalic
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 3
Rep:118
tjbiker031 will become famous soon enoughtjbiker031 will become famous soon enough
Default

Are you sure the switch is adjusted properly? I had that same issue on my 97 Mitsubishi Eclipse GST a few years back. I would suggest before you start fearing the worst, get a copy of the Dodge Ram service manual online (you can easily get one for free) and start troubleshooting with that. It will save you a bunch of time than scouring the internets looking and waiting for information and feedback.
__________________
Show your thanks with the REP icon.

Get your Factory Manuals here!! <link fixed>
Reply With Quote
  #4  
Old 03-19-2013, 08:25 AM
tjbiker031's Avatar
tjbiker031 tjbiker031 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2011
Location: Bradenton, FL
Age: 30
Posts: 307
Gender: Male
Vehicle: 2002 Dodge Ram
Trim Level: SLT - Quad Cab
Color: Graphite Metalic
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 3
Rep:118
tjbiker031 will become famous soon enoughtjbiker031 will become famous soon enough
Default

Ok taking a look at ShopKey at school because this issue keeps nagging at me.

It says under troubleshooting to
1. Ensure no DTC (codes) are in the system.
2. Re-adjust brake switch
3. Test servo (cruise system under hood)
4. check vacuume leaks
5. check linkage for throttle and cruise.
6. Check wireing connectors

then it goes on in depth more about defective PCM and a bad servo.
__________________
Show your thanks with the REP icon.

Get your Factory Manuals here!! <link fixed>

Last edited by tjbiker031; 03-19-2013 at 08:28 AM.
Reply With Quote
  #5  
Old 03-21-2013, 10:17 PM
Franklg42 Franklg42 is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2013
Location: Nashville Tn.
Age: 48
Posts: 3
Gender: Male
Vehicle: 2008 Dodge Ram Big Horn
Trim Level: Big Horn
Color: Red
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
Franklg42 is on a distinguished road
Default Wheel sensor?

I replaced my drivers side wheel bearing about a week ago and my truck is doing the same thing. The connector didn't match up correctly, however the pins were right so i reformed the connector to make it fit. I wonder if I have the wrong part.
Reply With Quote
  #6  
Old 03-22-2013, 07:38 AM
tjbiker031's Avatar
tjbiker031 tjbiker031 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2011
Location: Bradenton, FL
Age: 30
Posts: 307
Gender: Male
Vehicle: 2002 Dodge Ram
Trim Level: SLT - Quad Cab
Color: Graphite Metalic
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 3
Rep:118
tjbiker031 will become famous soon enoughtjbiker031 will become famous soon enough
Default

Quote:
Originally Posted by Franklg42 View Post
I replaced my drivers side wheel bearing about a week ago and my truck is doing the same thing. The connector didn't match up correctly, however the pins were right so i reformed the connector to make it fit. I wonder if I have the wrong part.

More than likely. The issue when the connectors dont fit is that the wireing could be wrong and not allow certain componets to work and in some cases (generically) can fry electrical componets.
__________________
Show your thanks with the REP icon.

Get your Factory Manuals here!! <link fixed>
Reply With Quote
  #7  
Old 03-27-2013, 08:59 PM
IndyGreg IndyGreg is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2013
Location: Indianapolis
Posts: 4
Gender: Male
Vehicle: 2002 Dodge Ram SLT Quad 2wd
Trim Level: SLT
Color: Silver
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
IndyGreg is on a distinguished road
Default Checking for codes this weekend.

Quote:
Originally Posted by tjbiker031 View Post
Ok taking a look at ShopKey at school because this issue keeps nagging at me.

It says under troubleshooting to
1. Ensure no DTC (codes) are in the system.
2. Re-adjust brake switch
3. Test servo (cruise system under hood)
4. check vacuume leaks
5. check linkage for throttle and cruise.
6. Check wireing connectors

then it goes on in depth more about defective PCM and a bad servo.
I should finally have time to check for codes this weekend. As for #2 When I installed new brake switch it says they can only be adjusted once.
What I confuses me is why holding brake pedal down allows the cruise control light to stay on? I could see a false signal being sent and turning off cruise when it thinks I have applied the brake. Even when working right the dash light should stay lit.
Reply With Quote
  #8  
Old 03-27-2013, 09:01 PM
IndyGreg IndyGreg is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2013
Location: Indianapolis
Posts: 4
Gender: Male
Vehicle: 2002 Dodge Ram SLT Quad 2wd
Trim Level: SLT
Color: Silver
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
IndyGreg is on a distinguished road
Default

Quote:
Originally Posted by Franklg42 View Post
I replaced my drivers side wheel bearing about a week ago and my truck is doing the same thing. The connector didn't match up correctly, however the pins were right so i reformed the connector to make it fit. I wonder if I have the wrong part.
So your light is turning itself back off? Have you tried to press brake pedal and see if it will stay lit? If so maybe it could be a wheel speed sensor?
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 08:31 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum