DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Electrical


Notices

Electrical 3rd Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 03-24-2013, 02:40 PM
jcmorozz jcmorozz is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2012
Location: PNW
Posts: 10
Gender: Male
Vehicle: 2003 Dodge Ram 2500 Quad Cab
Trim Level: SLT
Color: Black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
jcmorozz is on a distinguished road
Default 2003 2500 Not Turning Over

The engine is not turning over, no engine rotation what so ever.
This is not be expertise so I'm hoping someone can point me to the right direction. The battery has been checked and doesnt seem to be the issue (My lights, etc are work fine and the lights arent dimming when starting)

Around two months ago, I noticed the ground terminal had exhibited a large amount of corrision which i cleaned with the battery cleaner and coated. I didn't have any issues really after that till a month later it took several attemps turning the key to turnover, i again checked the ground terminal and recleaned/coated it. It has been firing up a little rougher then when i first bought the truck but nothing major. The other night i got nothing when turning it over. I checked the terminal and noticed the bolt had actually corroded in half and the body ground (attaches to left fender and directly to terminal) was loose. I got it roughed in there and held, after around half hour of denking with it, it fired up out of the blue, i got it home and immediately after cutting the engine, it was back to not firing.

I contrubited this to the ground terminal so just replaced it all together with an aftermarket bronze, wire brushing all connections, etc. Same issues. Im assuming it is my starter and it just happened to be around the same time as my ground terminal issues. Im going to get a voltameter now..

Pretty much I'm hoping someone with experience can help diagnose this with the simply fact the truck was a little rougher over the last month starting and then after continually trying to fire it up, it was able to once.
Reply With Quote
Sponsored links
  #2  
Old 03-25-2013, 07:34 AM
tjbiker031's Avatar
tjbiker031 tjbiker031 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2011
Location: Bradenton, FL
Age: 30
Posts: 307
Gender: Male
Vehicle: 2002 Dodge Ram
Trim Level: SLT - Quad Cab
Color: Graphite Metalic
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 3
Rep:118
tjbiker031 will become famous soon enoughtjbiker031 will become famous soon enough
Default

Start by checking grounds for battery and starter. Make sure you are getting voltage to the starter during start-up. Do you have any DTC's (codes)?
__________________
Show your thanks with the REP icon.

Get your Factory Manuals here!! <link fixed>
Reply With Quote
  #3  
Old 03-29-2013, 08:21 PM
jcmorozz jcmorozz is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2012
Location: PNW
Posts: 10
Gender: Male
Vehicle: 2003 Dodge Ram 2500 Quad Cab
Trim Level: SLT
Color: Black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
jcmorozz is on a distinguished road
Default

Still no luck
Replaced Ground Terminal
Replaced Battery with new Optima (it was exhibiting unusually signal), it was working but had one dead cell?
Benched Tested Starter - Good
Removed BullyDog Tune
No DTC Codes (Ground was pulled so i wont get any more codes but it has had a P0440 which is an emission system before)
Checked all Fuses, Relays

Only thing left would be a circuit or transmission relay issue?? Could it be the computers fried or the engine issues?
Reply With Quote
  #4  
Old 03-29-2013, 09:24 PM
jcmorozz jcmorozz is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2012
Location: PNW
Posts: 10
Gender: Male
Vehicle: 2003 Dodge Ram 2500 Quad Cab
Trim Level: SLT
Color: Black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
jcmorozz is on a distinguished road
Default

ohh yeah and earlier when i was messing with it, i was turning the ignition over and over and it finally turned on, it was sputturing and idling very rough (like the truck shaking). I turned it off and it turned back over twice more then back to nothing again.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 08:06 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum