DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Electrical


Notices

Electrical 3rd Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 03-30-2013, 10:20 PM
Chris65 Chris65 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2013
Location: Easley, SC
Posts: 82
Gender: Male
Vehicle: 2007 Dodge Ram
Trim Level: SLT
Color: silver
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:45
Chris65 is on a distinguished road
Question Right side flasher fast,front and rear works

Hey guys, I'm new here and found this forum in google.
because I was a active member in a motorcycle forum, I know, that this can be a powerful tool to be happy and stay happy with your vehicle.
I have following problem and I hope somebody can help me with troubleshooting:
I just bought a used 2007 Ram Quard Cab 4.7L
As I bought the truck, I asked the sales guy about the flasher right side.
The left side works fine, the right side flashes fast. Front and rear was working, just faster. The sales guy told me, that this might be a bulb, because they having sometimes high resistance in the socket.
I am car technician and well...- I know that happens. So I bought the truck.
Today I checked the blinker and found the horror.
After removing both headlights, I found, that somebody connected per hanging wire the right head light with the right head light. The wires was just drilled together and taped. the left headlight connector is already slightly overheated.
I found the wires from the left headlight in the plastick pipe. I bought 2 new connectors and connected it to the original wires. The wires was dead.
Now it started getting weired. I checked under the dash and found non-original wiring, 3 wires from the OBD-Connecto wires was capped and routed in a aftermarked wiring harness. I removed all covers left side and found on top of the kombi under the trim a power commander.
Beside I hate these useless wannabe improvement tries, everything was rednecked together like a 15 year old would do.
I followed the wires from the light switch and it seems like they go in direction kombi instrument.
Now my question: does anybody knows how the light wiring is routed?, is the light module integrated into the kombi instrument? can it be that by trying to do professional work done by a dummy the light module got shot?
I was not going further, because I called the dealer. Monday I will show him the mess. He already told me that he does not want to take the car back, but I will try to get some money back. I don't trust anybody anyway- seen too much. I know I can do it by my self, just need the information and maybe a wiring diagram.
Does anybody knows, what a new light module or kombi instrument would cost, if it's shot?
Need to know how much I can tell the guy I want back.
He told me that his technicians checked the car- but if somebody would had checked it, he would have seen, that it is even very dangerous to run 2 headlights on one 0.5mm wire. My oppinion is, he should not had sold the car this way.
Like I said, I just found out after I checked the lights by my self. the wire from the right to the left headlight was hidden in the front bracket and not visilbe on first sight.
Or did anybody had this issue before?
I would be happy if I could solve the problem.
Thanks!
Reply With Quote
Sponsored links
  #2  
Old 03-30-2013, 11:34 PM
CdnoilRAM's Avatar
CdnoilRAM CdnoilRAM is offline
I push the skinny pedal


 
Join Date: Jul 2009
Location: Calgary, AB, CA
Age: 31
Posts: 17,273
Gender: Male
Vehicle: 2009 Blown 349 Hemi
Trim Level: Sport - Modified
Color: Brilliant Black/Snake Skin Green
Engine: 2009-2012 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 20
Rep:3277
CdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond reputeCdnoilRAM has a reputation beyond repute
Default

All the lights are controlled by the TIPM. I actually shorted out my passenger side low beam on my '07 and had to run a relay off of the driver side to make it work unless I replaced the entire TIPM.

When they do vehicle safety inspections they don't remove things like the headlights, they just ensure lights blink and turn-on when required. This could quite easily have been overlooked if they just did a safety inspection. Did you buy from a Chrysler dealership or just a used vehicle lot?
__________________
Sponsored by Bully's Performance
Green Mamba '09 Ram 1500 QCRB 4x4 Sport - dropped, blown, and bottle fed
Kurtis
Reply With Quote
  #3  
Old 03-31-2013, 10:44 AM
Chris65 Chris65 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2013
Location: Easley, SC
Posts: 82
Gender: Male
Vehicle: 2007 Dodge Ram
Trim Level: SLT
Color: silver
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:45
Chris65 is on a distinguished road
Thumbs up

Thanks a lot.
That's what I figured. I know that the newer models getting the signal from the flasher switch and the light switch into the Kombi. I know from VW Audi that the Light control module is in the Kombi.
Because the flasher issue and the light issue, I thought they are 2 independend issues or one big issue.
I also found out that the Module cost around $650 in e-bay. I would go safe and see if I can get a Kombi too, remove the dashboard, disable the chip tuning and get everything back to original.
I estimated a cost frame of $1200 - $1500 if I let somebody do it.
But...I don't trust nobody in repairing a car professional. Seen so much- on my charger they put the wheels on with impact wrench regardless there are chromed aluminum lug nuts and they destroyed them. and on my Beamer they was not even able to make a oil chage without stripping the thread in the oil pan and removing the oil filter before draining the oil.
The dealer was a car lot but he has a shop too. He told me his technicians checked the car and they haven't seen it. well I tolld him he better get some technicians and send the wannabe's home.

I hope to get at least $1000 out of him.


Thank you for your answer. helped a lot - realy.

Chris
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 02:36 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum