HID Flicker - DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum
DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum > Dodge Ram Forum - Mod Zone - Custom Dodge Ram Mods - Dodge Ram Performance > Custom Dodge Ram Interior and Exterior Lighting


Notices

Custom Dodge Ram Interior and Exterior Lighting HID - HALO - LED LIGHTING - UNDERBODY LIGHTING - TINTED/SMOKED/PAINTED TAILS - ETC.


Vendor Highlight! - Check these guys out for great deals on Parts and Accessories!
Reply
 
Thread Tools
  #1  
Old 03-29-2013, 02:22 PM
JustLiftIt JustLiftIt is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2013
Location: Charleston, SC
Age: 26
Posts: 21
Gender: Male
Vehicle: 2012 RAM 1500
Trim Level: Express
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
JustLiftIt is on a distinguished road
Default HID Flicker

I recently installed halo projectors (quad) with pre-installed H11 6000k HIDs. After doing so, only the HIDs flickered when activated.High beams are fine. Since Dodge's computers are weird, I ordered a completely new wiring harness for my setup, with built in capacitance and resistance. After doing this, they still flickered! I also hear a "humming buzz" from the inside of my truck when I activate the HIDs. Personally I think it is the ballasts. Anyone have any helpful information? Thanks!
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 03-31-2013, 11:32 PM
Draycal Draycal is offline
Dodge Ram Forum Newcomer
 
Join Date: Dec 2011
Location: Maryland
Age: 48
Posts: 7
Gender: Male
Vehicle: 2012 Dodge Ram
Trim Level: Big Horn
Color: Gray
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Draycal is on a distinguished road
Default

I have the same truck. I bought my kit from DDM tuning, 55 watt ballast with 8000k bulbs & error code eliminators. I did not use a relay harness. They have worked perfectly for almost 6 months now. I would not use the relay harness and try the error code eliminators. The buzzing noise your hearing is probably from that. Thanks, just a thought.
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement



All times are GMT -4. The time now is 08:48 PM.


Copyright © VerticalScope Inc. All rights reserved.
Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
vB.Sponsors