DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Powertrain > 4.7L PowerTech V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 04-30-2013, 11:32 PM
runovryou runovryou is offline
Dodge Ram Forum Newcomer
 
Join Date: Apr 2013
Location: Ohio
Age: 33
Posts: 1
Gender: Male
Vehicle: 2002 Dodge Ram
Trim Level: SLT
Color: Silver
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
runovryou is on a distinguished road
Default 02 Ram - Never ending problems, desp for help

hi all, I am getting pretty desperate and have talked to so many people and read up on so many things, but I'm at a dead end. I have an 02 with 4.7 1500 2wd. I bought it from a dealer last May with 79k on it and looked in very nice condition, drove well with exception of a few issues. When I test drove, it would like to stall when coming to a stop, unless you gave it a little gas, and AC wasn't cold. So the dealer said they'd take care of it all. They sent it to local Dodge dealer, who said the computer needed flashed and that'd take care of the stall issue.. and it seemed to. And they charged AC. All good. 4 months later, radiator blew and it got hot, gauge didn't pin, but got very warm. I stopped immediately. Let it cool, then idled home... less than a mile away. Put new radiator and thermostat in. Everything was good. I scrapped the old radiator, and when I broke off the plastic end tubes, they were packed full of a ton of thick yellowish crud. My guess was somebody had dumped stop leak in it, but I'm not sure. Anyway, stabalizing links went out, battery died, power windows stopped working, tire blew, spare was bad... and so on (over then next 2 months). Then the big one, started running bad, found out head gasket was blown. The guy I took it to for repair is a Ford dealer mechanic who does side work at home. He put new gaskets in, and sent the heads to the machine shop the dealer uses for machining. Got it back and had no heat. I pulled the two hoses that go through the fire wall and flushed using the garden hose. More of the crap like was in my radiator came out. Heat came back after a good flush. (this was around november/december). March it started running like crap again, so I took it back to the same guy because it resembled the symptoms when the head gasket blew. He said he pulled valve cover and rocker was just laying there. So he put new rocker and new lifter in. When I picked it up, it still had a small miss. The first time the key trick told me it was misfire code for cylinder 4. So a few days or weeks of driving like this with small miss.. engine light back on and said misfire cylinder 6. The guy never got back to me about looking at it again, so I pulled the even bank valve cover off hoping/expecting to see something obviously broke. Everything looked fine so I put it back together. The miss is getting worse and is now terrible. It runs ok when I'm a little on the gas, but shakes at idle or when cruising at a steady low rpm speed. I have new PCV valve, new coils, new plugs, have swapped coils and nothing has helped. I did 3 oil changes 500 miles apart after the head gasket repair... haven't noticed anything to note there. I also have noticed it seems to still be loosing coolant pretty steadily. And the strangest thing, is when I really get on the gas, the engine temp gauge drops way low.. then comes back up to normal. I started noticing this after the head gasket work, but can't say when it started doing this. I'm also not noticing coolant anywhere.. no obvious leaks, but not seeing any in the oil either. I've run sea foam, and marvel mystery oil during separate oil changes... it kept seeming like it might be a 'little' better after that, but then back to crap.. and still progressively getting worse. I don't know if it's worth mentioning but I have my muffler off, cat is still on though. Did that right after I got it. This is my third Ram, and have done the same with all... and it never seemed to cause a problem. My so called repair guy won't get back to me, and I'm not sure if it's because he's bad at returning calls, or if he knows there's some kind of bigger problem... but I have no warranty, I know that... he knows that, I'm not going after him with blame, I fully just want it fixed and will pay! All of the issues, I've looked up, and there are suggestions for each, but with all of this together, I'm not sure.. maybe somebody will know what's up with this thing!!?? I know the heads probably shouldn't have been machined, but at the time didn't know, and this guy said it wasn't a problem.. is that possibly what's causing this? I checked the cat after a 30 minute country road drive.. just looking to see if it was glowing red, which to the best of my knowledge would happen if the cat was plugged up. I feel like I've eliminated the PCV or plug or coil issues by replacing and swapping... As of today, the engine code is no longer for cylinder 6, but for random cylinder. I just want it to run good enough to sell, but as bad as the mis is right now, nobody is going to buy, not even cheap! That hurts too.. cause with the cost of the truck and then a few grand in repairs I've already done... makes me hang my head. I'm hoping that some of the guru's on here can point me in a direction that I can try or specifically request to be looked at by some other mechanic or shop. Or, if the truck is scrap, I'll just try to get back as much as I can for it... so far, I think $3000-3500 is about what a wholesaler has said he might pay for it. Sorry for the long post.. never ending problems, never ending description I guess! If anybody can help at all.. I thank you a head of time!
Reply With Quote
Sponsored links
  #2  
Old 05-03-2013, 03:01 PM
Chris65 Chris65 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2013
Location: Easley, SC
Posts: 82
Gender: Male
Vehicle: 2007 Dodge Ram
Trim Level: SLT
Color: silver
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:45
Chris65 is on a distinguished road
Default

There is a lemmon law even for used cars without warranty.
Did u checked the carfax?
Go to dodge-they can pull the repair history too.
Machining the head is ok. Don't worry.
The temp gauge thing seems like there is air in the system.
If there is air in the system, it can be the sensor gets the wrong temp and the pcm adjust the conditions.
Flush the system, set it on a slope with nose high. Flush the engine, fill cleaner in, run it on temp and mount the water hose sealed as possible and press the water out-lower hos off from radiaror, flush through the upper.
Refill the system and do the same 2-3times until the water is clear.
Refill with antifreeze and let it run, leave the pressure cap off. Increase slightly the rpm. If the water gets sucked in after the valve opened, fill untill the water does not disappear anymore.
Fill to the top and install the cap. Fill the expansion bottle and drive it wyth rpm over 2000.
When you're back, put a towel over the cap and gloves onyour hand and open slightly the cap while the engine is running. If you hear it suck and no water comes out, remove carefully and fill.
If you leave it sucking for a few seconds and then comes water, its ok.
Always put it on slope with nose high.
Do this, then u have at least the air out and eliminated one possible root cause.
The best is, if u got it apart anyway, put a new valve in.
When u done that, tell me if its better and what it does.
Reply With Quote
  #3  
Old 05-06-2013, 12:35 PM
Stampede4.7 Stampede4.7 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Sep 2010
Age: 37
Posts: 92
Gender: Male
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
Stampede4.7 is on a distinguished road
Default

Where in Ohio are? Sounds like the heater core was leaking, and they put stop leak in it.
Do what Chris65 said to do.

Stampede.
Reply With Quote
  #4  
Old 05-07-2013, 01:21 AM
BryGuy's Avatar
BryGuy BryGuy is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2012
Location: Londonderry, NH
Age: 43
Posts: 12
Gender: Male
Vehicle: 2002 Dodge Ram
Trim Level: SLT
Color: Dark Grey
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
BryGuy is on a distinguished road
Default

Who actually read this novel ???
Reply With Quote
  #5  
Old 05-09-2013, 08:36 AM
tjbiker031's Avatar
tjbiker031 tjbiker031 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2011
Location: Bradenton, FL
Age: 30
Posts: 307
Gender: Male
Vehicle: 2002 Dodge Ram
Trim Level: SLT - Quad Cab
Color: Graphite Metalic
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 4
Rep:118
tjbiker031 will become famous soon enoughtjbiker031 will become famous soon enough
Default

I'm considering it, not sure if i have time before class starts lol
__________________
Show your thanks with the REP icon.

Get your Factory Manuals here!! <link fixed>
Reply With Quote
  #6  
Old 05-09-2013, 10:25 AM
littlegirlbigtruck's Avatar
littlegirlbigtruck littlegirlbigtruck is offline
Dodge Ram Forum Senior Member!
 
Join Date: Apr 2013
Location: California
Age: 23
Posts: 116
Gender: Female
Vehicle: 2003 Dodge Ram 1500
Trim Level: SLT Sport
Color: Mineral Grey
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:23
littlegirlbigtruck is on a distinguished road
Default

Quote:
Originally Posted by tjbiker031 View Post
I'm considering it, not sure if i have time before class starts lol
Quote:
Originally Posted by BryGuy View Post
Who actually read this novel ???
Hey now boys, be nice. He is just looking for some help from fellow Dodge owners here, isn't that what this forum is largely for?


Runovryou - I am sorry to hear about ALL of the issues that you are having with your truck. One in particular I just had with my truck that is almost the same as yours, a 2003 4.7 L but with 4 wheel drive, and that was with my truck stalling when I came to a stop or was slowing down, such as in a neighborhood or parking lot. My idle was low and when I was at a stop I literally had to keep one foot on the gas and one on the break so that it wouldn't shut off.

I tried a ton of things and it cost me quite a bit of money to finally figure out what the issue was. First, I took it to a shop that took out my IAC valve and cleaned it, as well as adjusted my idle to be at a higher and more standard RPM level. That did not solve the issue at all. After this, my battery decided to go on the fritz (right after I had the work done, and it was a nearly new $300 Optima) - so I went into my local AutoZone and bought a new Optima battery and IAC valve (only $65 at AutoZone) hoping that these would fix the issue. It must have been my lucky day because the manager at AutoZone game me the number of a mechanic that he was good friends with. I met up with him after work that day with the intention of having him replace my IAC valve with the one that I just purchased, and while he was in my truck about ready to take my old one out, he found my problem in literally 30 seconds. My vacuum hose had come undone. As soon as he re-attached it all of my issues were solved. He put my new optima battery in and now my truck is running perfectly, but it was an EXTREMELY frustrating 10 days, so I know you must be beyond frustrated with ALL of the issues that you are having. I was extremely irritated with the first shop that I took my truck to because they charged me $180 to literally do nothing, and that they were STARING at the problem the entire time.

I got lucky in that my new mechanic is younger (not trying to offend anyone at all here) and has been working on newer trucks a lot more, while the first shop I took it to did a lot of work on older and classic cars. I realized, maybe they just didn't even think to check the vacuum hose (which they honestly should have) or maybe they didn't know. My point in this being, maybe your on-the-side after hours Ford mechanic isn't the right man for the job, and it might be worth your time and hard earned money to look into finding another mechanic for your truck's problems, since he doesn't seem to be helping you at all, AND is ignoring your attempts to contact him.

In conclusion: You might want to double check and make sure that your vacuum hose is tightly and properly connected and has no wear or cracks, and if it looks to be tightly attached and in good shape, consider replacing your IAC valve (like i said, a cheap fix and an easy installation.) I know that a lot of people with this same problem found that to be their solution. Another solution I saw was replacing an O2 sensor. Just a couple ideas that I found while researching my issue.

I really do hope that you get all of your truck's problems sorted out so that you can start enjoying your truck rather than stressing about it. I have only been a Dodge owner for a month, and while I love the look of my big truck, I am far less than impressed with it mechanically. I am honestly looking into selling it and getting a new Silverado. (Don't kill me guys, only a thought)



-End rant.
__________________
I am just a little girl in a big ass truck!
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 04:40 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum