DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - General Discussion > 2013 Dodge Ram Forum


Notices

2013 Dodge Ram Forum For specific discussion of the 2013 Dodge Ram!


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #111  
Old 05-15-2013, 03:38 PM
Kludt's Avatar
Kludt Kludt is offline
Dodge Ram Forum Junior Member
 
Join Date: May 2013
Location: Texas
Posts: 39
Gender: Male
Vehicle: 2013 Ram Quad Cab 1500
Trim Level: Express
Color: Bright Metallic Silver
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Kludt is on a distinguished road
Default

Yes seriously, you wouldn't think so, but with the right driver (me) it was able to do that any day of the week. I bought it from my stepbrother and he didn't go into all the settings in the tuner and wasn't as aggressive as I was in driving back then. After messing with the tuner I got it to do what most didn't think it could do. I proved to people over and over again.

As far as paying money to see it, people did. After my friends saw it first hand they had friends that wanted to see, so naturally I would bet them an amount of money that I could do it.
__________________
My Build Thread :
http://www.ramforumz.com/showthread.php?t=144661

Last edited by Kludt; 05-15-2013 at 03:40 PM.
Reply With Quote
  #112  
Old 03-09-2014, 10:53 PM
Pckrfan's Avatar
Pckrfan Pckrfan is offline
Dodge Ram Forum Member
 
Join Date: Aug 2013
Location: YYC
Posts: 65
Gender: Male
Vehicle: 2014 Ram 1500 Crew Cab
Trim Level: Sport
Color: White
Rep Power: 0
Rep:10
Pckrfan is on a distinguished road
Default

Problems with my Laramie Longhorn

Clunking sound right front when driving slow,speed over uneven ground. Seems to be a problem with the front sway bar and suspension. Going to the dealer.

Instrument cluster lights flickered no matter how low or how high they were set. Happened first three weeks I had it then no more flickering.

Several times the cluster will freeze up saying "channel 1 training" after I press the home link button and the garage door opens and closes. Have to shut the truck off to reset it.

Nav screen freezes. Have to,shut off the truck to reset it.

Oh, and projector housings and no HID's, I just threw that in for laughs

Last edited by Pckrfan; 03-09-2014 at 10:55 PM.
Reply With Quote
  #113  
Old 03-10-2014, 03:07 PM
Ottoman Ottoman is offline
Dodge Ram Forum Newcomer
 
Join Date: Dec 2013
Location: Bahrain
Age: 33
Posts: 27
Gender: Male
Vehicle: 2013 Ram 1500 RCSB
Trim Level: SLT
Color: Silver
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Ottoman is on a distinguished road
Default

off the lot I had tranny issues with the 8spd.. the dealer changed the valve body it didn't help in the end I needed a whole new Tranny.. been ok since..

I had the gauge/radio not turning off problem once.. after an engineering reset it's been ok..

I have creaking/Groaning brakes when at a dead stop and u slowly release them just enough to try and creep...
__________________
'13 1500 RCSB SLT 5.7 8spd 3.55
'14 Grand Cherokee Limited 5.7 8spd
Reply With Quote
  #114  
Old 09-12-2014, 01:22 AM
Kman521 Kman521 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2012
Location: Ontario, Canada
Posts: 133
Gender: Male
Vehicle: 2013 Dodge Ram
Trim Level: SLT
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:11
Kman521 is on a distinguished road
Default

Well I bought my 2013 in Dec 2012 and first I noticed the outside temp was way off but the dealer eventually fixed that with an update.
Next up when it gets cold the 6 speed doesn't upshift and holds a lower gear around the city because the factory engineers linked the outside temp gauge to the cold tranny shifting so it's not a defect it's by design.
On another cold winter day I start the truck and it goes into 4th right away and won't shift up or down so I stop and restart the engine and it corrects itself. Later the same day it happens again but this time it won't correct and the check engine light comes on. The next day I take it to the dealer but the trouble has gone, it did store a code but the dealer could not find any trouble. It hasn't been that cold since so I have no idea if it will come back. The inner fender liner on the drivers side was dropping out under the fender lip so the dealer wanted to charge me to adjust it but after arguing they adjusted it. When I got home it had dropped again so I called them and they ordered a new liner and replaced it a week later for no charge.
A week ago after driving on the highway I got home and went to wash the truck and the front drivers side rotor was smoking because the caliper was dragging. Today was the last straw. I took it into the dealer for the brake problem and I was told if it was not a warranty issue and they recommended work to be done and I refused I would have to pay $40. They checked it out and told me the front calipers seems fine but they found burn spots on the front rotors and a record effect (small grooves) on the back rotors. They wanted over $500 to service the brakes so I refused and paid the $40. I have under 28,000 KM on it.
I was so pissed that I drove to the Toyota dealer and traded the truck in for a 2014 Camry SE V6.
I've always owned North American vehicles but customer service has always sucked!
Time for a change.
Reply With Quote
  #115  
Old 09-13-2014, 01:16 PM
Thunderhorse's Avatar
Thunderhorse Thunderhorse is offline
The Sound of Eight Hooves

 
Join Date: Jun 2013
Location: Jacksonville, NC
Age: 23
Posts: 2,821
Gender: Male
Vehicle: 2013 Ram1500 4x4 8HP70 3.21LSD
Trim Level: Lone Star Quad Cab
Color: Bright White
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 4
Rep:500
Thunderhorse is a glorious beacon of lightThunderhorse is a glorious beacon of lightThunderhorse is a glorious beacon of lightThunderhorse is a glorious beacon of lightThunderhorse is a glorious beacon of lightThunderhorse is a glorious beacon of light
Default

Quote:
Originally Posted by Kman521 View Post
Well I bought my 2013 in Dec 2012 and first I noticed the outside temp was way off but the dealer eventually fixed that with an update.
Next up when it gets cold the 6 speed doesn't upshift and holds a lower gear around the city because the factory engineers linked the outside temp gauge to the cold tranny shifting so it's not a defect it's by design.
On another cold winter day I start the truck and it goes into 4th right away and won't shift up or down so I stop and restart the engine and it corrects itself. Later the same day it happens again but this time it won't correct and the check engine light comes on. The next day I take it to the dealer but the trouble has gone, it did store a code but the dealer could not find any trouble. It hasn't been that cold since so I have no idea if it will come back. The inner fender liner on the drivers side was dropping out under the fender lip so the dealer wanted to charge me to adjust it but after arguing they adjusted it. When I got home it had dropped again so I called them and they ordered a new liner and replaced it a week later for no charge.
A week ago after driving on the highway I got home and went to wash the truck and the front drivers side rotor was smoking because the caliper was dragging. Today was the last straw. I took it into the dealer for the brake problem and I was told if it was not a warranty issue and they recommended work to be done and I refused I would have to pay $40. They checked it out and told me the front calipers seems fine but they found burn spots on the front rotors and a record effect (small grooves) on the back rotors. They wanted over $500 to service the brakes so I refused and paid the $40. I have under 28,000 KM on it.
I was so pissed that I drove to the Toyota dealer and traded the truck in for a 2014 Camry SE V6.
I've always owned North American vehicles but customer service has always sucked!
Time for a change.
So you had a thermometer issue that was fixed, a piece of plastic didn't fit right, and it was also fixed, and a weird transmission experience. Then you had the brake issue.

I would say there has only been 1 serious issue with your truck, and that is the brakes. Since your truck is under warranty, that is more of a dealer issue.

Seems like most issues here are minor and are mostly related to software, rather than actual reliability.
__________________
Huskyliner Weatherbeaters, door edge guards, Line-X bedliner, Kryptek Typhon Cordura seat covers w/ MOLLE panels (review), Console Vault (install/review), Bilstein 4600s awaiting installation.
Reply With Quote
  #116  
Old 09-13-2014, 02:26 PM
Kman521 Kman521 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2012
Location: Ontario, Canada
Posts: 133
Gender: Male
Vehicle: 2013 Dodge Ram
Trim Level: SLT
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:11
Kman521 is on a distinguished road
Default

Quote:
Originally Posted by Thunderhorse View Post
So you had a thermometer issue that was fixed, a piece of plastic didn't fit right, and it was also fixed, and a weird transmission experience. Then you had the brake issue.

I would say there has only been 1 serious issue with your truck, and that is the brakes. Since your truck is under warranty, that is more of a dealer issue.

Seems like most issues here are minor and are mostly related to software, rather than actual reliability.
I was only posting all the issues I've had.
The brakes and tranny stuck in 4th are not minor in my opinion.
NTF means there's a good possibilty the trouble will occur again when it gets cold again.
Rotors and brake pads are considered normal wear items according to the dealer and that's why they wouldn't cover them.
It appears that is the same with other manufacturers too but since I have only 27,700 km on the truck it didn't instill too much confidence for the future. Who wants to replace or turn rotors that often. I don't drive the truck hard or brake hard.
The transmission problem sticking in 4th gear is programmed into the truck in the event there is a transmission malfunction and is a limp mode.
Just google "Ram stuck in 4th gear" here's one thread.
http://www.**************/forums/sho...d.php?t=343782

One other thing I haven't mentioned is the black paint is terrible. I've had a black vehicle before and it never marked as easy as this one.
I have my truck serviced at a different dealer than where I bought it because I bought the truck a 2 hour drive away so maybe that makes a difference or maybe I'm just one of the unlucky ones.

Anyway the truck will be gone next week and I'll be moving on.
Reply With Quote
  #117  
Old 09-13-2014, 02:34 PM
Thunderhorse's Avatar
Thunderhorse Thunderhorse is offline
The Sound of Eight Hooves

 
Join Date: Jun 2013
Location: Jacksonville, NC
Age: 23
Posts: 2,821
Gender: Male
Vehicle: 2013 Ram1500 4x4 8HP70 3.21LSD
Trim Level: Lone Star Quad Cab
Color: Bright White
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 4
Rep:500
Thunderhorse is a glorious beacon of lightThunderhorse is a glorious beacon of lightThunderhorse is a glorious beacon of lightThunderhorse is a glorious beacon of lightThunderhorse is a glorious beacon of lightThunderhorse is a glorious beacon of light
Default

I am aware of what it means when it goes into 4th. Has it happened more than once? What was the code?
__________________
Huskyliner Weatherbeaters, door edge guards, Line-X bedliner, Kryptek Typhon Cordura seat covers w/ MOLLE panels (review), Console Vault (install/review), Bilstein 4600s awaiting installation.
Reply With Quote
  #118  
Old 09-14-2014, 01:42 PM
Breathing Borla's Avatar
Breathing Borla Breathing Borla is offline
Dodge Ram Forum Senior Member!
 
Join Date: May 2013
Location: IL
Posts: 481
Gender: Male
Vehicle: 2013 Ram 1500 Sport 4x4
Trim Level: Sport
Color: Maximum Steel
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 2
Rep:89
Breathing Borla will become famous soon enough
Default

first mistake

buying the crysler slush box 6 speed

just my .02

should of traded it on a tundra, great truck. I have owned 3 tundras and 3 tacomas over the years. this is my first ram, decided to take a chance. so far so good.

but I have the ZF
__________________

2013 Ram Sport Crew 4x4, 5.7, 8-speed, 3.92, Borla
2010 LTD Tundra DC, 4x4 RW Wheels 33" Cooper Maxx
2001 tundra, 2000 tundra
1995.5 Tacoma, 1997 Tacoma, 1998 Tacoma

Last edited by Breathing Borla; 09-14-2014 at 03:50 PM.
Reply With Quote
  #119  
Old 09-14-2014, 04:29 PM
Kman521 Kman521 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2012
Location: Ontario, Canada
Posts: 133
Gender: Male
Vehicle: 2013 Dodge Ram
Trim Level: SLT
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:11
Kman521 is on a distinguished road
Default

Quote:
Originally Posted by Thunderhorse View Post
I am aware of what it means when it goes into 4th. Has it happened more than once? What was the code?
It's happened three times and here is the info I was given for the code.

Originally Posted by TransEngineer
P0882 means that, at startup, when the PCM commanded the trans relay to close (to feed 12V power to the transmission), there was no power coming from the relay. This puts the trans in full limp-in.

Problem could be the relay itself, or the wiring between relay and trans, or the wire from PCM to relay (that PCM uses to turn the relay on). But in any event, the problem is NOT inside the trans anywhere (unless you have a blatant dead short to ground within the trans solenoid, which I've never seen).

The trans relay is part of the Power Distribution Center (PDC, the black box behind the battery that houses the fuses). I'm not sure whether the trans relay can be replaced individually (like a fuse), or whether it's part of the main PDC circuit board (which means if it's bad you must replace the entire PDC = big $$$).

If your truck is running OK now, then consider yourself blessed. If it acts up again, check the wiring and connectors to see if there are any obvious problems (corroded pins, pins pushed part-way out, etc.). Dealers have a diagnostic procedure to check the wiring etc. for this fault.
Reply With Quote
  #120  
Old 09-14-2014, 04:32 PM
Kman521 Kman521 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2012
Location: Ontario, Canada
Posts: 133
Gender: Male
Vehicle: 2013 Dodge Ram
Trim Level: SLT
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:11
Kman521 is on a distinguished road
Default

Quote:
Originally Posted by Breathing Borla View Post
first mistake

buying the crysler slush box 6 speed

just my .02

should of traded it on a tundra, great truck. I have owned 3 tundras and 3 tacomas over the years. this is my first ram, decided to take a chance. so far so good.

but I have the ZF
I bought my 2013 in Dec 2012 and I couldn't get the 8 speed then.

Neighbor bought a 2013 Ram Sport 8 speed just after I bought mine and no troubles so far.
Other neighbor has a Tacoma with no troubles either.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 12:33 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum