DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - General Discussion > 2013 Dodge Ram Forum
Register Advertising Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read


Notices

2013 Dodge Ram Forum For specific discussion of the 2013 Dodge Ram!


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 07-15-2013, 12:03 AM
logan1080 logan1080 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2013
Location: canada
Posts: 12
Gender: Male
Vehicle: 2013 ram 1500
Trim Level: sport
Color: maximum steel blue
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
logan1080 is on a distinguished road
Default Truck fails to start, warning lights....

2013 ram 1500 with hemi, 800 miles on the clock. The truck has failed to start when I hit the start button 3 times now. It has had several rough starts, fires right away but stutters or a subtle knock. No engine codes, no DLC's with engine scanner. However I noticed in the screen between odo and spedo two lights flash back and forth, the engine temp warning light which is red and another symbol not in the manual: a steering wheel with a "!" beside it, this is also a red light. No idea what this light means. The engine temp light makes no sense because it comes on even before the engine is warmed up. Anyone know what the other symbol means? I'm going to the dealer but I'd still like to know what the mystery light is.
Reply With Quote
Sponsored links
  #2  
Old 07-15-2013, 06:59 AM
maw76's Avatar
maw76 maw76 is offline
Dodge Ram Forum Senior Member
 
Join Date: Jul 2013
Location: Montreal Canada
Age: 39
Posts: 134
Gender: Male
Vehicle: 2013 RAM 1500 QC
Trim Level: Outdoorsman
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:49
maw76 is on a distinguished road
Default

the steering wheel light is cause our steering system is electric, it flashes like oil, engine light at start up cause it is verifying the system that all sensors and connections are good. If it stays flashing after the fact that the engine is started then you have a problem.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement







All times are GMT -4. The time now is 09:53 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors