DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram – 2002 to 2008 Dodge Ram Trucks > Powertrain > 5.7L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 07-13-2013, 04:52 PM
SMARacing SMARacing is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2012
Location: NJ Shore
Age: 36
Posts: 3
Gender: Male
Vehicle: 2005 Ram 1500 SLT
Trim Level: SLT
Color: White
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
SMARacing is on a distinguished road
Exclamation HELP Engine Stall

******HELP- Phantom stalling issues ************

2005 Ram 1500 QC 4x4 SLT 5.7L with 160k miles

Stalls when I stop, then accelerate. RPMs will raise a few hundred then just drop to stall. All electronics will stay on; can start truck back up right away. Only way to drive is to brake with left foot while maintaining 1000 rpm on throttle, then slowly releasing brake while slowly increasing throttle. It's a PIA. When driving/WOT it does not stall, no issues.

I have spoken to a lot of buddy's that are gear heads and mechanics. Read a ton of online forum information.

Here is what I have replaced so far-

•Throttle body (drive by wire IAC/TPS internal) replaced because it was reading 18% on scanner and wouldn't go above that.
•PCV valve
•EGR valve
•Camshaft sensor
•Crankshaft sensor
•Wire and plugs (copper)
•Rear VSS- this is only code it's thrown

•Checked wires on MAP sensor by wiggling to see if corroded as I read this on several forums but it was ok

•Checked fuel pressure on rail and it was ok 62 psi

I am running out of ideas , it seems like this is a major dodge issue.

A few people tell me it could still be-

•PCM needs to be flashed; I know dodge released an update for this year/motor PCM. I have one dodge tech telling me it will help and another saying it won't.

•or PCM is bad and I need a new one......

• or there is a vacuum leak; if this is it- how do I check for this? Where do I look?


Any suggestions or ideas would be greatly appreciated...
Reply With Quote
Sponsored links
  #2  
Old 07-13-2013, 05:03 PM
mb power wagon's Avatar
mb power wagon mb power wagon is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2013
Location: manitoba
Posts: 362
Gender: Male
Vehicle: 2007 dodge power wagon
Trim Level: power wagon
Color: black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:68
mb power wagon will become famous soon enough
Default

i have heard of this. and i read somewhere on here that another member had the same issue and found it was a corroded wire on the back of his under hood fuse block. it may not be the problem but it's not hard to look and see if it may be there that is causing the problem. i have also heard that a failing fuel injector may cause this issue. the ecm will close all injectors and force the engine to stall but will start right back up as soon as the improper reading is normal as in when the engine shuts down.
__________________
Reply With Quote
  #3  
Old 07-14-2013, 12:41 AM
SMARacing SMARacing is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2012
Location: NJ Shore
Age: 36
Posts: 3
Gender: Male
Vehicle: 2005 Ram 1500 SLT
Trim Level: SLT
Color: White
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
SMARacing is on a distinguished road
Default

Thanks Mb. I'll look into both of those possibilities.
Reply With Quote
  #4  
Old 07-17-2013, 04:40 PM
musclej musclej is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2013
Posts: 3
Gender: Male
Vehicle: 2005
Rep Power: 0
Rep:10
musclej is on a distinguished road
Default

I dont want to hi jack this thread but, I have a 2005 dodge ram 1500 5.7l hemi with around 86,000 miles had the truck for about 5 days now and I was coming up to a stop sign and as I pressed the brake my truck suddenly just shut off the power steering went out but lights were still on. The check engine light was on, previous owner said he had it checked out and they told him there was carbon build up but wasnt sure exactly where it was. Any ideas would be nice. Im going to take it to my mechanic to do the maintenance for that amount of miles.


7-18-13
Update had the check engine light checked and threw a EGR valve code.

Last edited by musclej; 07-18-2013 at 01:47 PM.
Reply With Quote
  #5  
Old 07-19-2013, 10:28 PM
Simple guy Simple guy is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jun 2013
Location: Pottstown, Pa
Age: 27
Posts: 247
Gender: Male
Vehicle: 2003 Ram 1500
Trim Level: SLT QC 4x4
Color: Mineral grey
Engine: 2002-2003 360ci (5.9L) Magnum V8 245hp 335lb/ft
Rep Power: 2
Rep:109
Simple guy will become famous soon enoughSimple guy will become famous soon enough
Default

Quote:
Originally Posted by musclej View Post
I dont want to hi jack this thread but, I have a 2005 dodge ram 1500 5.7l hemi with around 86,000 miles had the truck for about 5 days now and I was coming up to a stop sign and as I pressed the brake my truck suddenly just shut off the power steering went out but lights were still on. The check engine light was on, previous owner said he had it checked out and they told him there was carbon build up but wasnt sure exactly where it was. Any ideas would be nice. Im going to take it to my mechanic to do the maintenance for that amount of miles.


7-18-13
Update had the check engine light checked and threw a EGR valve code.
As soon as I read carbon build I immediately suspected egr. sorry i'm just seeing this today, a day late and a dollar short I guess.
__________________
Reply With Quote
  #6  
Old 07-19-2013, 10:43 PM
mb power wagon's Avatar
mb power wagon mb power wagon is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2013
Location: manitoba
Posts: 362
Gender: Male
Vehicle: 2007 dodge power wagon
Trim Level: power wagon
Color: black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:68
mb power wagon will become famous soon enough
Default

there has to be a reason as to why you had a carbon buildup. try finding why it happened. was it only a city truck with very little use? or only someone who never worked the engine? or is there a different problem causing that kind of carbon buildup.
SMARacing any luck getting it figured out yet?
__________________
Reply With Quote
Reply

Bookmarks

Tags
2005 1500 slt, 5.7, engine stall

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 09:12 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum