DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Suspension


Notices

Suspension 3rd Gen Dodge Ram Suspension Problems and Questions


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 05-21-2013, 01:56 AM
Twinkeys0816's Avatar
Twinkeys0816 Twinkeys0816 is offline
Dodge Ram Forum Junior Member
 
Join Date: Apr 2013
Location: Calgary
Age: 25
Posts: 35
Gender: Male
Vehicle: 2006 Dodge Ram 1500
Color: Black
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
Twinkeys0816 is on a distinguished road
Default front bilstein 5100

hi guys! just got my bilstein 5100 last week just the front and finished installing them this weekend, got them set up on max height. Now i got a squeaking sound at the rear, It sounds like its coming from the leaf spring or the shocks I cant tell cause when i push the rear end down to find where the squeaking sound is coming from both leaf and shocks move at the same time. And i dont think the shocks are bad too. Has anyone came up with something like this before. And i wont get the rear bilstein soon too. so any ideas to help get rid of the squeaking sound ? i would really really aprreaciate it and thank you in advance.
Reply With Quote
Sponsored links
  #2  
Old 07-29-2013, 05:46 PM
jacewd jacewd is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2013
Location: Nova Scotia
Age: 30
Posts: 1
Gender: Male
Vehicle: 2008 Dodge Ram
Trim Level: SXT
Color: Black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
jacewd is on a distinguished road
Default

I had the same thing happen about 2 weeks after installing the Bilsteins up front, I put grease in a syringe and greased the spring shackles and the shock mounts, sprayed the fluid film in between as many leafs as i could. haven't heard a squeak for almost a month.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 08:27 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum