DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Powertrain > 4.7L PowerTech V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 07-30-2013, 08:14 AM
KH85 KH85 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2013
Location: NC
Posts: 5
Gender: Male
Vehicle: 2006 Dodge Ram 1500
Trim Level: SLT
Color: Black
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
KH85 is on a distinguished road
Default CEL Flashing...Stutter at low throttle

Greetings all, I'm new to this awesome community. As I'm googling my symptoms, I kept running into this site so I figured I'd go ahead and join. There's a lot of great info and great people on here. Glad to be a member, and I hope I can contribute.

I'm having an issue with my '06 Ram 1500 (4.7L). My gas mileage went way down, so I changed all the spark plugs and even changed all 4 O2 sensors. Once I was done, I disconnected the battery and waited a little bit before re-connecting it. I didn't drive it the rest of the day, and it ran fine to work the next morning. However when I got back in it later that morning, it started stuttering really bad as I was pulling out of my parking spot and the CEL started flashing.

I put it back in my parking spot and started my googling to see what it could be. Long story short, at the end of the day the CEL went solid so I was able to drive it to Advance Auto to get a diagnostic. I notice that it only stuttered when I barely had the throttle open (so I'm figuring something with the air flow). Here are the codes that I received at Advance:

P0300: Random Misfire
P0138: O2 Sensor High Voltage 1/2
P0133: O2 Sensor Slow Response 1/1
P0153: O2 Sensor Slow Response 2/1
P2096: Post Cat Fuel Trim too lean Bank 1
P2098: Post Cat Fuel Trim too lean Bank 2

I got home and disconnected the battery for about 15 minutes, and went back out. I started it up and of course the CEL was off because it reset. The truck actually ran fine until I got to my turn around point about 1.5 miles from my home. It started stuttering again, and the CEL started flashing. I limped it home and parked it. Before I turned it off, I could hear something "knocking".

I'm pounding my head against the wall and don't know where to start. Any help would be appreciated.
Reply With Quote
Sponsored links
  #2  
Old 07-30-2013, 09:42 AM
Simple guy Simple guy is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jun 2013
Location: Pottstown, Pa
Age: 27
Posts: 247
Gender: Male
Vehicle: 2003 Ram 1500
Trim Level: SLT QC 4x4
Color: Mineral grey
Engine: 2002-2003 360ci (5.9L) Magnum V8 245hp 335lb/ft
Rep Power: 2
Rep:109
Simple guy will become famous soon enoughSimple guy will become famous soon enough
Default

I was just reading a post on a Chrysler forum about someone having just changed their spark plugs and O2 sensors because of noticed drop in MPG. He started getting P2096 His problem was inferior quality O2 sensors. Did you replace your OEM o2 sensors with Bosch? Do you still have the old O2 sensors?
__________________
Reply With Quote
  #3  
Old 07-30-2013, 10:55 AM
KH85 KH85 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2013
Location: NC
Posts: 5
Gender: Male
Vehicle: 2006 Dodge Ram 1500
Trim Level: SLT
Color: Black
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
KH85 is on a distinguished road
Default

I put Bosch o2 sensors in it. I suppose I could put the old ones back in and see if the problem is still there.
Reply With Quote
  #4  
Old 07-30-2013, 11:32 AM
Simple guy Simple guy is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jun 2013
Location: Pottstown, Pa
Age: 27
Posts: 247
Gender: Male
Vehicle: 2003 Ram 1500
Trim Level: SLT QC 4x4
Color: Mineral grey
Engine: 2002-2003 360ci (5.9L) Magnum V8 245hp 335lb/ft
Rep Power: 2
Rep:109
Simple guy will become famous soon enoughSimple guy will become famous soon enough
Default

Yeah i'd swap them and see what you get. I mean before replacing them you weren't getting any codes?
__________________
Reply With Quote
  #5  
Old 07-30-2013, 04:14 PM
KH85 KH85 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2013
Location: NC
Posts: 5
Gender: Male
Vehicle: 2006 Dodge Ram 1500
Trim Level: SLT
Color: Black
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
KH85 is on a distinguished road
Default

A few months ago I would randomly get codes dealing with my o2 sensors but they would go away. I wasn't getting any misfiring like I am now. I figured since I was getting bad gas mileage I'd do the spark plugs and o2 sensors at the same time. I've heard that the tips are really sensitive if they touch anything. So I'm concerned the old sensors may be jacked up since I just took them out an threw them in a plastic bag.
Reply With Quote
  #6  
Old 07-31-2013, 10:43 PM
KH85 KH85 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2013
Location: NC
Posts: 5
Gender: Male
Vehicle: 2006 Dodge Ram 1500
Trim Level: SLT
Color: Black
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
KH85 is on a distinguished road
Default

Quote:
Originally Posted by Simple guy View Post
I was just reading a post on a Chrysler forum about someone having just changed their spark plugs and O2 sensors because of noticed drop in MPG. He started getting P2096 His problem was inferior quality O2 sensors. Did you replace your OEM o2 sensors with Bosch? Do you still have the old O2 sensors?
Sure enough, I put the old O2 sensors in and it's back to running normal; however, I now have some rattling in my cats, so I'm going to start researching if I need to replace them. Any advice?

BTW, just the new spark plugs made my MPG jump from 13 to 16.
Reply With Quote
  #7  
Old 07-31-2013, 10:51 PM
deanhinsley1963's Avatar
deanhinsley1963 deanhinsley1963 is offline
Dodge Ram Forum Junior Member
 
Join Date: Jun 2013
Location: Hugo,OK.
Age: 51
Posts: 36
Gender: Male
Vehicle: 2004 Dodge Ram 1500
Trim Level: slt
Color: silver
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:12
deanhinsley1963 is on a distinguished road
Default

KH85 How many miles do you have on the truck? Mines got 104,000 I just bought it and dont know if they have been changed or not. But I dont get but 14mpg.
Reply With Quote
  #8  
Old 07-31-2013, 11:04 PM
Simple guy Simple guy is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jun 2013
Location: Pottstown, Pa
Age: 27
Posts: 247
Gender: Male
Vehicle: 2003 Ram 1500
Trim Level: SLT QC 4x4
Color: Mineral grey
Engine: 2002-2003 360ci (5.9L) Magnum V8 245hp 335lb/ft
Rep Power: 2
Rep:109
Simple guy will become famous soon enoughSimple guy will become famous soon enough
Default

they should be fine as long as there's no oils or water on them.

I mean I'm not saying leave them in permanently. If you see better results with the old ones back in get NTK brand o2 sensors.
__________________

Last edited by Simple guy; 07-31-2013 at 11:11 PM.
Reply With Quote
  #9  
Old 08-04-2013, 03:40 PM
KH85 KH85 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2013
Location: NC
Posts: 5
Gender: Male
Vehicle: 2006 Dodge Ram 1500
Trim Level: SLT
Color: Black
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
KH85 is on a distinguished road
Default

Quote:
Originally Posted by deanhinsley1963 View Post
KH85 How many miles do you have on the truck? Mines got 104,000 I just bought it and dont know if they have been changed or not. But I dont get but 14mpg.
Mine just turned 105k. After changing the plugs and putting the old O2 sensors in, I ran it up from NC to OH and got 16 mpg. My CEL came back on with the P0430 code (Bank 2 Cat below threshold). I'm hoping that replacing my cats/exhaust system to high flow will help it even more. I also will have my new K&N Cold Air Intake waiting on my porch.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 04:31 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum