DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Electrical


Notices

Electrical 3rd Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 07-31-2013, 01:57 AM
jadkins jadkins is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2013
Posts: 2
Gender: Male
Vehicle: 2004 ram 1500
Rep Power: 0
Rep:10
jadkins is on a distinguished road
Default help

I have an 04 1500 and i keep losing all lights on dash radio goes off most of the time dash goes black and red light comes on almost everytime the door looks cycle.if the headlights are on high beam they kick to low beams when dash comes back on.not sure but think i might lose taillights sometimes when this happens .i was getting a c code that said short in door locks.so i pulled the fuse for the door locks still happened and it threw a different code replaced door lock fuse and now it wont throw any codes.everything comes back to normal after a few seconds. I have noticed to that the odometer will lose a couple miles on it when this happens.when u shut truck off and on the first time of turning on ignition after this happens the tac and speedo go all the way up then back to zero only the first time u turn key on after.the truck still runs fine.but the problem is getting more frequent.any help would be appreciated
Reply With Quote
Sponsored links
  #2  
Old 07-31-2013, 02:12 AM
Canadian Hemi Pride's Avatar
Canadian Hemi Pride Canadian Hemi Pride is offline
Dodge Ram Forum Member


 
Join Date: Jan 2013
Location: Hamilton, Ontario
Age: 22
Posts: 6,196
Gender: Male
Vehicle: 2008 Dodge Ram 1500
Trim Level: SXT 4x4
Color: Silver/ Black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 10
Rep:2767
Canadian Hemi Pride has a reputation beyond reputeCanadian Hemi Pride has a reputation beyond reputeCanadian Hemi Pride has a reputation beyond reputeCanadian Hemi Pride has a reputation beyond reputeCanadian Hemi Pride has a reputation beyond reputeCanadian Hemi Pride has a reputation beyond reputeCanadian Hemi Pride has a reputation beyond reputeCanadian Hemi Pride has a reputation beyond reputeCanadian Hemi Pride has a reputation beyond reputeCanadian Hemi Pride has a reputation beyond reputeCanadian Hemi Pride has a reputation beyond repute
Default

It sounds like it could be your alternator could be on it's way out. I am not for sure, but I know a problem that occurs when the alternator is messed up is lighting going in and out.
__________________
Brandon...Check out my build thread here
For any help or advice, send me a message or post on my profile here
Any Leveling/offset questions? Go HERE
Tow mirrors up for all the haters
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 08:31 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum