DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Powertrain > 5.2L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 08-01-2013, 11:31 AM
brink5 brink5 is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2013
Posts: 8
Gender: Male
Vehicle: 1999 Dodge Ram 1500
Trim Level: Laramie
Color: White
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:10
brink5 is on a distinguished road
Default Idle Problems

Hello,

At a loss as to what is causing my problem.
I recently acquired a 99 ram 1500 5.2L, and have ran into a problem that on start up the engine doesn't want to idle. I took apart the throttle body and cleaned everything, replaced the IAC and TPS but none of that fixed it. It only really does it in the morning after it has been sitting all night. To keep it running I just keep my foot on the gas for all of about a minutes, then I can let off the gas and it will idle just fine, maybe idle a little lower than normal, but it won't die. No problems driving it after that. The problem seems to be intermittent, as some mornings it fires right up and idles perfectly.

Any thoughts or direction would be greatly appreciated.

No codes have been thrown.

Thanks
Reply With Quote
Sponsored links
  #2  
Old 08-01-2013, 12:49 PM
Warlock III's Avatar
Warlock III Warlock III is offline
Has Internet Tourettes
 
Join Date: Aug 2010
Posts: 6,222
Gender: Male
Vehicle: 1995 Ram 1500
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 10
Rep:1694
Warlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant future
Send a message via AIM to Warlock III Send a message via Yahoo to Warlock III
Default

Check the upstream 02 sensors. Unplug them one at a time and see if either one makes a difference.
__________________
Remove the head from a serpent, and the body dies. Remove a head from a Hydra and two more grow to take its place.
Reply With Quote
  #3  
Old 08-01-2013, 01:52 PM
brink5 brink5 is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2013
Posts: 8
Gender: Male
Vehicle: 1999 Dodge Ram 1500
Trim Level: Laramie
Color: White
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:10
brink5 is on a distinguished road
Default

I'm getting ready to leave town for a few days, but will definitely do that when I get back and let you know if that fixed it! Thanks.
Reply With Quote
  #4  
Old 08-11-2013, 08:38 PM
brink5 brink5 is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2013
Posts: 8
Gender: Male
Vehicle: 1999 Dodge Ram 1500
Trim Level: Laramie
Color: White
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:10
brink5 is on a distinguished road
Smile

Had a chance today to work on the truck.
Went to the auto store and had them scan it even though no check engine light was on. There was a code!

The code was for a bad o2 sensor, though it was for the one down stream, not the upstream ones.

So long story short I changed out that sensor this afternoon. I'll keep an eye on it over the next couple days and see if that fixes it. I'll keep you posted.
Reply With Quote
  #5  
Old 08-11-2013, 11:32 PM
Gen1dak Gen1dak is offline
Dodge Ram Forum Senior Member!
 
Join Date: Aug 2011
Location: MS Gulf Coast
Posts: 1,437
Gender: Male
Vehicle: 1990 RamCharger
Color: Red
Engine: 1988-1991 318ci (5.2L) LA V8 140hp
Rep Power: 0
Rep:74
Gen1dak will become famous soon enough
Default

I'm wondering if you have a weak battery or poor connection messing with the computer. A partial loss of power will cause the computer to have memory issues that will affect things like idle quality.
Reply With Quote
  #6  
Old 08-16-2013, 02:12 PM
brink5 brink5 is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2013
Posts: 8
Gender: Male
Vehicle: 1999 Dodge Ram 1500
Trim Level: Laramie
Color: White
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:10
brink5 is on a distinguished road
Default

Well, changing the down stream O2 sensor didn't help the situation.
I have ordered the up stream 02 sensor, and will change that out when I get a chance.
The truck has some hail damage that is getting fixed right now, so I won't have the truck back till sometime next week. I'll see what happens once I get that replaced!

Had the batter checked, and it appears to be a good battery.

Though when we started the car, the voltage was at 13.9.
They guy said it should be around 14.5. So maybe the alternator is going bad?

Do you think that may be causing my problems?
Reply With Quote
  #7  
Old 08-16-2013, 04:09 PM
JonMiller1985 JonMiller1985 is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2013
Location: Fort Benning
Age: 28
Posts: 1
Gender: Male
Vehicle: 1998 Dodge Ram, Laramie SLT 2W
Trim Level: Laramie SLT
Color: Rusted
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:10
JonMiller1985 is on a distinguished road
Default

Hey all,
New to the forums and new to working on my own.

I have a 1998 Dodge Ram 1500, Laramie SLT, 2WD 5.2L V8 and have a myriad of issues with it. I bought it due to needing another vehicle. It was previously used as a farm truck.

Currently, I am throwing codes for a Lower Left Bank O2 sensor. I know I have one on the cat and the other is right before the muffler. I for the life of me cant figure out which is the lower left bank, and I cant seem to find a straight answer on how many O2 sensors I am even supposed to have. Looking under the truck, I have found the two. I bought one O2 sensor but the plug doesnt fit the O2 by the muffler, but it LOOKS like it will fit the O2 on the cat.
Any advice for a newbie will be greatly appreciated.
Reply With Quote
  #8  
Old 08-19-2013, 11:04 PM
brink5 brink5 is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2013
Posts: 8
Gender: Male
Vehicle: 1999 Dodge Ram 1500
Trim Level: Laramie
Color: White
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:10
brink5 is on a distinguished road
Default

I got the up stream O2 sensor changed out tonight. Have to wait till tomorrow to see if that fixes it... keeping fingers crossed!
Reply With Quote
  #9  
Old 08-26-2013, 02:01 PM
brink5 brink5 is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2013
Posts: 8
Gender: Male
Vehicle: 1999 Dodge Ram 1500
Trim Level: Laramie
Color: White
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:10
brink5 is on a distinguished road
Smile

Good news guys. Problem is fixed!
Could kick myself though, turns out the new IAC I had put in wasn't functioning properly. Swapped out the IAC, and the truck has been running great every since.

Think my problem was I purchased a BWD sensor from oreilly, rather than spending the extra cash to get the factory sensor.

Appreciated everyone's help and insight!

Case closed.
Reply With Quote
Reply

Bookmarks

Tags
iac, idle, idle problems, tps

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 09:22 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum