DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Electrical


Notices

Electrical 2nd Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 01-23-2013, 01:45 AM
Wickedwelder's Avatar
Wickedwelder Wickedwelder is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2013
Location: Casper Wyoming
Age: 37
Posts: 6
Gender: Male
Vehicle: 1999 Sport 4x4
Trim Level: Sport
Color: Green
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:10
Wickedwelder is on a distinguished road
Question Instrument cluster help

What would cause my entire instrument cluster to quit working? Right now I have no gauges that work and when I first start it the odometer will flash the mileage about 3 times and then it just says "no bus". I've checked all the fuses in the cab and under the hood and they are all good. I have no idea what to check next. Anyone ever had this happen or have any ideas?
Thanks in advance for any help

Gary
__________________
"Courage is being scared to death but saddling up anyway" John Wayne
Reply With Quote
Sponsored links
  #2  
Old 01-23-2013, 12:00 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 15
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

Could be a bad cluster, a problem with the wiring, or even a ABS module issue. The no bus message means the data bus is inoperative and you will likely need professional help to diagnose the problem. Checking the fuses is a start. Did you check to see if there is actually power across them or just to see if they were blown?
Reply With Quote
  #3  
Old 01-23-2013, 12:26 PM
Wickedwelder's Avatar
Wickedwelder Wickedwelder is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2013
Location: Casper Wyoming
Age: 37
Posts: 6
Gender: Male
Vehicle: 1999 Sport 4x4
Trim Level: Sport
Color: Green
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:10
Wickedwelder is on a distinguished road
Default

I just checked to see if the fuses where blown. I'll check power across them this weekend.
Everything was working back in June when I took it to a trans shop. Don't know what they did but they couldn't get it started for a week, they ended up swapping out the PCM with one from the wrecking yard. After that it started right up, but my gauges haven't worked since. Just about all the warning lights are lit up on it also(abs,check engine,seat belt, emergency brake, and fuel light)
I was told at one time that I needed to get the PCM flashed, but not sure what that entails.
__________________
"Courage is being scared to death but saddling up anyway" John Wayne
Reply With Quote
  #4  
Old 01-23-2013, 12:46 PM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 15
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

Trans was out, huh? That makes me wonder if any wiring got pinched, the crank sensor in particular.
Reply With Quote
  #5  
Old 01-23-2013, 02:45 PM
Wickedwelder's Avatar
Wickedwelder Wickedwelder is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2013
Location: Casper Wyoming
Age: 37
Posts: 6
Gender: Male
Vehicle: 1999 Sport 4x4
Trim Level: Sport
Color: Green
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:10
Wickedwelder is on a distinguished road
Default

Trans wasn't out, they replaced two of the shift selonoids and replace the park pin. I had swapped the trans out a couple weeks before that and everything was working when I took it in.
Really don't want to have to put it in a shop if I don't have to since its my daily driver. Hoping its something I fix at the house. I'll check the power across the fuses and go from there.
__________________
"Courage is being scared to death but saddling up anyway" John Wayne
Reply With Quote
  #6  
Old 08-04-2013, 08:03 PM
CB56 CB56 is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2012
Location: W.PA
Posts: 10
Gender: Male
Vehicle: 2000 Dodge Ram 2500
Trim Level: Laramie SLT
Color: Silver
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
CB56 is on a distinguished road
Default

Did you find the electrical problem? If you did, I sure would appreciate it if you would post it. I have the same problem. I will start trouble shooting in a day or two. I will post if and when I find something. CB
Reply With Quote
  #7  
Old 03-11-2014, 11:10 PM
Another brick Another brick is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2014
Location: Indio, CA
Posts: 9
Gender: Male
Vehicle: 1998 Dodge Ram 2500 Diesel 4x4
Trim Level: Used
Color: Green
Engine: 1996-1998 359ci (5.9L) Cummins 12-valve Diesel I6 215hp 440lb/ft(manual), 180hp 420lb/ft(auto)
Rep Power: 0
Rep:10
Another brick is on a distinguished road
Default

Is there room in the boat for me, too?
Aggravating issue, at the least~
Reply With Quote
  #8  
Old 03-15-2014, 11:41 AM
FilthyDog's Avatar
FilthyDog FilthyDog is offline
Dodge Ram Forum Member
 
Join Date: Nov 2012
Location: Boulder, Colorado
Age: 35
Posts: 73
Gender: Male
Vehicle: 1999 Dodge Ram 1500
Trim Level: SLT Laramie
Color: White
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
FilthyDog is on a distinguished road
Default

I just finally solved this problem on my truck. The final culprit was the overhead console. SO add that to the list of items to unplug while trouble shooting.
__________________
Mods: Hughes FI Intake, Stainless Steel Short Headers(generic ebay), Rebuilt Cylinder Heads, K&N Cold Air Intake, IAT Mod, Hughes STAGE 1 MODIFIED O.E.M. THROTTLE BODY, High Flow exhaust, LineX Bed Liner
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 04:35 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum