DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 4TH Generation Dodge Ram 2009+ Dodge Ram Trucks > Powertrain > 5.7L (345 cu in) HEMI V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 08-24-2013, 09:51 AM
BadX BadX is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2013
Location: Conover NC
Posts: 11
Gender: Male
Vehicle: 2013 Ram 1500
Trim Level: Black Top
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
BadX is on a distinguished road
Default CAI Installed Check engine light on

Hey guys. I just installed the K&N 77-1561KP on my new 2013 Dodge Ram 5.7. I followed the instructions to a "T" and when I cranked the truck to listen for any air sucking sounds I noticed the check engine light was on. Everything is plugged up and no air leaks. Test drove it and the truck ran great and actually feels like it has more power but the check engine light is still on. Any ideas?
Reply With Quote
Sponsored links
  #2  
Old 08-24-2013, 11:49 AM
gpff214's Avatar
gpff214 gpff214 is offline
Dodge Ram Forum Member

 
Join Date: Jul 2013
Location: DFW, TX
Age: 39
Posts: 88
Gender: Male
Vehicle: 2013 Ram 1500 CC
Color: Maximum Steel
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:47
gpff214 is on a distinguished road
Default

Did you disconnect the negative battery terminal after installing? Im far from an expert but that's what ive been to to do when installing a CAI so that the MAF sensor can relearn.... Good luck hopefully this will help.
__________________
KCCO
Reply With Quote
  #3  
Old 08-24-2013, 12:20 PM
Grubrunner's Avatar
Grubrunner Grubrunner is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jan 2012
Posts: 4,241
Gender: Male
Vehicle: 2014 Jeep Grand Cherokee SRT8
Rep Power: 12
Rep:3872
Grubrunner has a reputation beyond reputeGrubrunner has a reputation beyond reputeGrubrunner has a reputation beyond reputeGrubrunner has a reputation beyond reputeGrubrunner has a reputation beyond reputeGrubrunner has a reputation beyond reputeGrubrunner has a reputation beyond reputeGrubrunner has a reputation beyond reputeGrubrunner has a reputation beyond reputeGrubrunner has a reputation beyond reputeGrubrunner has a reputation beyond repute
Default

If you're certain that all your connections/installation is correct, disconnect the battery's negative terminal and let it sit for 30mins then reconnect.

Let us know what happens....
__________________
Truck was sold today [5/19]. I got an offer I couldn't turn down. I had no more need for a pickup so I cut it loose. About to purchase a '14 Jeep SRT8 this week.

Grub out!
Reply With Quote
  #4  
Old 08-24-2013, 03:01 PM
brondondolon's Avatar
brondondolon brondondolon is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2011
Location: carson city nv
Posts: 320
Gender: Male
Vehicle: 2009 Dodge Ram 5.7L hemi
Trim Level: 1500
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 4
Rep:177
brondondolon has a spectacular aura aboutbrondondolon has a spectacular aura about
Default

i had the same issue with my S&B. my MAF sensor was out of position a tiny bit. check it out. on my truck the connecting clip should be pointing up and tilted towords the front of the truck a tiny bit. the CEL went away right after i fixed it and restarted the truck. also if you dont have a scanner you could take it to a auto shop even some autozones and they will scan it. if you do that report back with the codes. hope this helps and good luck.
__________________
S&B CAI, Y-pipe muffler delete, Diablo intune, Hemifever, custom tune, 180 thermostat, BT oil catch can, smoked, tail light and 3rd breaklight, 5000k retrosolutions 55w HID headlights and fog lights, LED in all exterior lamps, red calipers. Future mods: 87mm TB, 3000 stall torque converter
Reply With Quote
  #5  
Old 08-24-2013, 07:17 PM
BadX BadX is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2013
Location: Conover NC
Posts: 11
Gender: Male
Vehicle: 2013 Ram 1500
Trim Level: Black Top
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
BadX is on a distinguished road
Default

Thanks for the help guys. I left the truck at the shop, rode the motorcycle home since the weather is so nice. I will try some of the suggestions and will report back on Monday.
Reply With Quote
  #6  
Old 08-26-2013, 03:42 PM
BadX BadX is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2013
Location: Conover NC
Posts: 11
Gender: Male
Vehicle: 2013 Ram 1500
Trim Level: Black Top
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
BadX is on a distinguished road
Default

Okay. Un-hooked battery for 30 mins made sure the air temp sensor was aligned to let air flow through it. CEL still lit up. Took it to local Auto zone and pulled the code and it was for the air temp sensor. Emailed K&N telling and to my surprise got a response quickly. There were supposed to be two air temp sensor wire extensions one for the 09-12 and one for the 13's. I got the one for the 09-12 and its not getting a connection so they are sending me out one today but the bad thing is they are in California and I am in NC so it will be next week before it arrives since the holiday weekend.
Reply With Quote
  #7  
Old 08-27-2013, 12:08 AM
brondondolon's Avatar
brondondolon brondondolon is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2011
Location: carson city nv
Posts: 320
Gender: Male
Vehicle: 2009 Dodge Ram 5.7L hemi
Trim Level: 1500
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 4
Rep:177
brondondolon has a spectacular aura aboutbrondondolon has a spectacular aura about
Default

ah thats a bummer. good news though you got it all figured out. i hate that feeling though of having to wait on installing a mod. i just encountered that installing my tuner. i plugged it in and theni got some error and had to wait till morning to call diablo and resolve everything. but at least now you know what the problem is.
__________________
S&B CAI, Y-pipe muffler delete, Diablo intune, Hemifever, custom tune, 180 thermostat, BT oil catch can, smoked, tail light and 3rd breaklight, 5000k retrosolutions 55w HID headlights and fog lights, LED in all exterior lamps, red calipers. Future mods: 87mm TB, 3000 stall torque converter
Reply With Quote
  #8  
Old 08-28-2013, 08:46 PM
BadX BadX is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2013
Location: Conover NC
Posts: 11
Gender: Male
Vehicle: 2013 Ram 1500
Trim Level: Black Top
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
BadX is on a distinguished road
Default

To my surprise the wire extensions arrived today from K&N. Put the correct extension on, unhooked the battery for 30 min's went back out and bada bing the CEL light was off.

I am surprised at the customer service from K&N, you don't find that much these days and would recommend them to anybody.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 01:39 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum