DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - General Discussion > 2013 Dodge Ram Forum


Notices

2013 Dodge Ram Forum For specific discussion of the 2013 Dodge Ram!


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 04-19-2013, 07:35 PM
Bosstone95's Avatar
Bosstone95 Bosstone95 is offline
Dodge Ram Forum Newcomer
 
Join Date: Apr 2013
Location: Canada
Posts: 17
Gender: Male
Vehicle: 2013 Dodge Ram 1500 SXT
Trim Level: SXT
Color: Silver
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Bosstone95 is on a distinguished road
Default Help: EVIC Settings Not Saving Key-Off Power Delay

Good-day,

Recently bought a 2013 Ram 1500 SXT after many good years with my Dakota.

I am having issues with the EVIC not saving settings. I want the radio to not stay on when I exit the vehicle. When I go under Settings in EVIC and change the Key-Off Power Delay to "Off" rather than the factory default "45 Seconds" it never saves the settings. It functions like I want it to and powers off the radio when the key is turned to off the first time. Then, when I start the truck up again to test it, the settings are back on "45 Seconds" and the radio stays on for 45 seconds after I turn the key to off and even if I open the door and exit the vehicle.

Is there something I should be doing to save the settings instead of just changing them and them backing out of the Settings screen?

Thanks so much for your help!
Reply With Quote
Sponsored links
  #2  
Old 04-20-2013, 12:39 AM
dubstalon dubstalon is offline
Dodge Ram Forum Newcomer
 
Join Date: Apr 2013
Location: Broken Arrow OK
Age: 38
Posts: 8
Gender: Male
Vehicle: 2013 RAM 1500
Trim Level: Express
Color: Mineral gray
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
dubstalon is on a distinguished road
Default

Mine is doing the same thing. Dealership tried to tell me it was a feature. Then after I proved to them it was an issue the shop foreman said it is an issue and the engineers at chrysler are working on it. I called a week later and they said no news yet. He called me back later that day and said the engineers say the bcm is the problem. Waiting for that to come in now. Should be in next week. Hope that helps
Reply With Quote
  #3  
Old 04-20-2013, 07:46 AM
Bosstone95's Avatar
Bosstone95 Bosstone95 is offline
Dodge Ram Forum Newcomer
 
Join Date: Apr 2013
Location: Canada
Posts: 17
Gender: Male
Vehicle: 2013 Dodge Ram 1500 SXT
Trim Level: SXT
Color: Silver
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Bosstone95 is on a distinguished road
Default

Thanks so much for replying. I'm glad I'm not the only one, as I was scared I picked up a lemon or something!

I will see what the dealership says and mention the BCM to them.

I wonder if this will come out as a recall eventually?

Thanks again!
Reply With Quote
  #4  
Old 07-08-2013, 10:46 AM
toober's Avatar
toober toober is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2013
Location: South Texas
Age: 42
Posts: 173
Gender: Male
Vehicle: 2013 Ram 1500
Trim Level: Tradesman
Engine: 2013-20?? 220ci (3.6L) Pentastar 305hp 269lb/ft
Rep Power: 0
Rep:26
toober is on a distinguished road
Default

What is the status of this on your end? I have the same problem and the service dept says they "have never heard of this problem before". What a croc. It's a double issue. Page 291 of the manual says the key off power delay should be "canceled" when the front doors are opened. This does not happen either along with the issue of not saving the time delay change. I'm taking my truck in soon for this same issue.
__________________
.
Reply With Quote
  #5  
Old 07-13-2013, 02:52 PM
toober's Avatar
toober toober is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2013
Location: South Texas
Age: 42
Posts: 173
Gender: Male
Vehicle: 2013 Ram 1500
Trim Level: Tradesman
Engine: 2013-20?? 220ci (3.6L) Pentastar 305hp 269lb/ft
Rep Power: 0
Rep:26
toober is on a distinguished road
Default

Update: Service guy says they contacted Chrysler engineers and it is a problem with the radio, for both reasons, the key off power delay not saving and for the radio not shutting off with the key out when the door is opened. He says they had to order another radio and it will be here in a few days and take about 1.5 hours to replace.
__________________
.
Reply With Quote
  #6  
Old 08-12-2013, 06:49 PM
Bosstone95's Avatar
Bosstone95 Bosstone95 is offline
Dodge Ram Forum Newcomer
 
Join Date: Apr 2013
Location: Canada
Posts: 17
Gender: Male
Vehicle: 2013 Dodge Ram 1500 SXT
Trim Level: SXT
Color: Silver
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Bosstone95 is on a distinguished road
Default

Interesting. I haven't been back to the dealer since I bought the truck. I'm going back to the dealer for an oil change soon, so we'll see what they say!
Reply With Quote
  #7  
Old 08-13-2013, 09:14 AM
toober's Avatar
toober toober is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2013
Location: South Texas
Age: 42
Posts: 173
Gender: Male
Vehicle: 2013 Ram 1500
Trim Level: Tradesman
Engine: 2013-20?? 220ci (3.6L) Pentastar 305hp 269lb/ft
Rep Power: 0
Rep:26
toober is on a distinguished road
Default

Replacing the radio took care of the problem. But the 2nd stock radio they put in quit completely after 7 days. They have now replaced that one and I'm hoping the 3rd one does what any kenwood, jvc, or $10 unit from Fry's could do perfectly.
__________________
.
Reply With Quote
  #8  
Old 08-21-2013, 01:08 PM
Chilly807 Chilly807 is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2013
Location: Nova Scotia, Canada
Posts: 14
Gender: Male
Vehicle: 2013 Dodge Ram SXT
Trim Level: SXT
Color: Blue
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Chilly807 is on a distinguished road
Default

Mine does the same thing, and I've also noticed that the screen setup options for the EVIC screen don't seem to be there, and the ones that are are ineffective. I've heard there's an ongoing replacement of the body control module in the 2013's currently.

I have an appt at the dealer on Monday the 26th, I'll keep you posted as to what happens there.

Sean
Reply With Quote
  #9  
Old 08-23-2013, 07:38 AM
Rusty289's Avatar
Rusty289 Rusty289 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Aug 2013
Location: New Brunswick Canada
Age: 43
Posts: 393
Gender: Male
Vehicle: 2014 Ram 1500 Crew Cab
Trim Level: Sport
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 1
Rep:117
Rusty289 will become famous soon enoughRusty289 will become famous soon enough
Default

My 2009 has been doing that since it was new, they changed some part and it was still the same so I got tired of dealing with them and never got it fixed.

Honestly they don't know how to fix anything it seems.
__________________
If ya can't Dodge it, Ram it!!!
Reply With Quote
  #10  
Old 08-26-2013, 03:05 PM
Chilly807 Chilly807 is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2013
Location: Nova Scotia, Canada
Posts: 14
Gender: Male
Vehicle: 2013 Dodge Ram SXT
Trim Level: SXT
Color: Blue
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Chilly807 is on a distinguished road
Default

Okay.. appointment with dealer to look into my problem (same as Bosstone95's) was today. They checked it over, had no problem re-creating the issue. They called Dodge's tech line, who informed them that yes, there definitely IS a problem with the system, and that as of today, there is no fix for it. Apparently it's pretty common in the SXT's at least. Mine won't retain the time delay settings other than the 45 second default after the key is turned off, and also doesn't turn off the radio as soon as the front doors are opened.

Mine DOES turn off the radio after the default 45 seconds have elapsed, however, which is a blessing. Some of the other trim levels have had problems with the radio simply NOT turning off at all. Apparently some of the Uconnect 8.4 systems do this.

The most they could tell me was that it was a problem with the body control module and the radio not "communicating" properly, or having a "conflict" of some sort.

They suggested I check with them at each service to determine if a fix had been found, which I will do. The engineering work-around for now is to turn off the radio when key is removed if the owner has concerns.

Mine's more of a quirk than anything else, so I can live with it. I suspect the issue existed when the trucks were released last year, and it was considered minor enough to not delay the release of the model year.

Sean
Reply With Quote
Reply

Bookmarks

Tags
evic, key-off power, radio

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 12:13 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum