DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - General Discussion > 2013 Dodge Ram Forum


Notices

2013 Dodge Ram Forum For specific discussion of the 2013 Dodge Ram!


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #11  
Old 08-26-2013, 06:08 PM
toober's Avatar
toober toober is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2013
Location: South Texas
Age: 42
Posts: 173
Gender: Male
Vehicle: 2013 Ram 1500
Trim Level: Tradesman
Engine: 2013-20?? 220ci (3.6L) Pentastar 305hp 269lb/ft
Rep Power: 0
Rep:26
toober is on a distinguished road
Default

Quote:
Originally Posted by Chilly807 View Post
They called Dodge's tech line, who informed them that yes, there definitely IS a problem with the system, and that as of today, there is no fix for it.
My dealer said Chrysler told them to replace the radio to fix this very same problem on my truck. They replaced the radio, and now it saves my settings.
__________________
.
Reply With Quote
  #12  
Old 08-27-2013, 07:50 AM
Chilly807 Chilly807 is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2013
Location: Nova Scotia, Canada
Posts: 14
Gender: Male
Vehicle: 2013 Dodge Ram SXT
Trim Level: SXT
Color: Blue
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Chilly807 is on a distinguished road
Default

Quote:
Originally Posted by toober View Post
My dealer said Chrysler told them to replace the radio to fix this very same problem on my truck. They replaced the radio, and now it saves my settings.
Your truck has the basic evic display and the Uconnect 3.0 radio, the same as mine, correct?
Reply With Quote
  #13  
Old 08-27-2013, 06:13 PM
toober's Avatar
toober toober is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2013
Location: South Texas
Age: 42
Posts: 173
Gender: Male
Vehicle: 2013 Ram 1500
Trim Level: Tradesman
Engine: 2013-20?? 220ci (3.6L) Pentastar 305hp 269lb/ft
Rep Power: 0
Rep:26
toober is on a distinguished road
Default

Yes, the cheapy 3.0 I got in the Tradesman.
__________________
.
Reply With Quote
  #14  
Old 08-27-2013, 07:19 PM
Chilly807 Chilly807 is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2013
Location: Nova Scotia, Canada
Posts: 14
Gender: Male
Vehicle: 2013 Dodge Ram SXT
Trim Level: SXT
Color: Blue
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Chilly807 is on a distinguished road
Default

Interesting.. next time I'm at the dealership I'll suggest that as a fix and see what they say. I'm not going to put too much heat on them yet, I'll give them a chance to find it themselves. There's also the possibility that the fix you had done won't work on mine because of some software changes or radio updates that we don't know about.

Thanks,

Sean
Reply With Quote
  #15  
Old 09-09-2013, 03:55 PM
Bosstone95's Avatar
Bosstone95 Bosstone95 is offline
Dodge Ram Forum Newcomer
 
Join Date: Apr 2013
Location: Canada
Posts: 17
Gender: Male
Vehicle: 2013 Dodge Ram 1500 SXT
Trim Level: SXT
Color: Silver
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Bosstone95 is on a distinguished road
Default

Thanks for the info Chilly807 & toober.

My dealership gave me the same speech about checking with each service and went on to say that mine "is the only one that they have heard having this problem." That kind of ticked me off, as it was almost as if the problem is somehow mine and not theirs? I told them when I come in for my next oil change, I will expect an update from them as to the solution to the problem.

The other issue I have is that I set the EVIC to be KPH instead of MPH because I'm in Canada and it does it for the most part except when I set my cruise. It usually ALWAYS displays the set cruise in MPH for some odd reason.

Like you said, it's more of a annoyance than anything. No issues with the rest of the truck. I can live with it, but I'd like it to be working 100%.

Chilly, out of interest what kind of fuel economy are you getting per L/100KM?

Last edited by Bosstone95; 09-09-2013 at 03:59 PM.
Reply With Quote
  #16  
Old 09-09-2013, 08:09 PM
Chilly807 Chilly807 is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2013
Location: Nova Scotia, Canada
Posts: 14
Gender: Male
Vehicle: 2013 Dodge Ram SXT
Trim Level: SXT
Color: Blue
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Chilly807 is on a distinguished road
Unhappy

Quote:
Originally Posted by Bosstone95 View Post
Thanks for the info Chilly807 & toober.

My dealership gave me the same speech about checking with each service and went on to say that mine "is the only one that they have heard having this problem." That kind of ticked me off, as it was almost as if the problem is somehow mine and not theirs? I told them when I come in for my next oil change, I will expect an update from them as to the solution to the problem.

The other issue I have is that I set the EVIC to be KPH instead of MPH because I'm in Canada and it does it for the most part except when I set my cruise. It usually ALWAYS displays the set cruise in MPH for some odd reason.

Like you said, it's more of a annoyance than anything. No issues with the rest of the truck. I can live with it, but I'd like it to be working 100%.

Chilly, out of interest what kind of fuel economy are you getting per L/100KM?
Mine does the exact same thing, displays the cruise set speed in mph.. too funny. Except once recently it didn't display the cruise speed at all, and my odometer didn't return after I turned the cruise off. The next day it was back to what passes for normal!!
We just got back from a 3000 km road trip to the US, driving at a highway cruise of 65 mph through Maine, New Hampshire, and Massachusetts we go almost exactly 11 l/100km.
Reply With Quote
  #17  
Old 09-09-2013, 08:20 PM
Chilly807 Chilly807 is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2013
Location: Nova Scotia, Canada
Posts: 14
Gender: Male
Vehicle: 2013 Dodge Ram SXT
Trim Level: SXT
Color: Blue
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Chilly807 is on a distinguished road
Default

Mine does the exact same thing, displays the cruise set speed in mph.. too funny. Except once recently it didn't display the cruise speed at all, and my odometer didn't return after I turned the cruise off. The next day it was back to what passes for normal!!
We just got back from a 3000 km road trip to the US, driving at a highway cruise of 65 mph through Maine, New Hampshire, and Massachusetts we got almost exactly 11 l/100km for the round trip. That was overall driving, including some secondary roads, a bit of stop and go in towns and small cities, and some easy highway cruising.
On the way down we got 10.4 l/100 km, which is better than the truck is rated for, the trip back must have been more uphill driving, we got 11.3 l/100 km.

It's interesting, I can get better economy on secondary roads at about 80-90 km/h than I can at 105 km/h on the highway. It's easy to get 10.8 l/100 out of the truck, which frankly impresses the hell out of me. Even if I put my foot in it once in a while it's still decent.

I've been running 89 octane mid-grade gas, not regular.

Having said that, we made a 200 km round trip on the highway today hauling a 3000 lb horse trailer, averaged about 23-24 l/100 km. I can't even complain about that, there's no shortage of power on hills and the truck handles it well.

Sean

Last edited by Chilly807; 09-09-2013 at 08:22 PM.
Reply With Quote
  #18  
Old 09-11-2013, 07:19 AM
Bosstone95's Avatar
Bosstone95 Bosstone95 is offline
Dodge Ram Forum Newcomer
 
Join Date: Apr 2013
Location: Canada
Posts: 17
Gender: Male
Vehicle: 2013 Dodge Ram 1500 SXT
Trim Level: SXT
Color: Silver
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Bosstone95 is on a distinguished road
Default

10.8 is amazing. I get between 13-14, but I don't do a lot of highway and drive mostly back roads for short distances. I also don't run mid-grade though I probably should based on what you're getting.

I'm just happy to hear someone else is having the same problem as me with the EVIC. I will make sure to let you know if the dealership fixes it. Sounds like other than that, you are enjoying your truck just like I am and that's the main thing.
Reply With Quote
  #19  
Old 09-11-2013, 09:46 AM
Chilly807 Chilly807 is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2013
Location: Nova Scotia, Canada
Posts: 14
Gender: Male
Vehicle: 2013 Dodge Ram SXT
Trim Level: SXT
Color: Blue
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Chilly807 is on a distinguished road
Cool

Yeah, the truck has impressed me. My first Dodge product, hopefully not the last.
If the EVIC did this forever I wouldn't be too upset at all, as long as it gets no worse. Right now it's a quirk, not a real problem.

Sean
Reply With Quote
  #20  
Old 10-16-2013, 09:55 AM
Chilly807 Chilly807 is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2013
Location: Nova Scotia, Canada
Posts: 14
Gender: Male
Vehicle: 2013 Dodge Ram SXT
Trim Level: SXT
Color: Blue
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Chilly807 is on a distinguished road
Default

Mine's going back in on Friday morning for a recall with the stability control, I'm going to ask them to re-visit the radio issue and see if there's any new developments.

Sean
Reply With Quote
Reply

Bookmarks

Tags
evic, key-off power, radio

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 06:18 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum