DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, & Solutions - Maintenance & Repair > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Electrical


Notices

Electrical 3rd Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
FGT Motorsport
Bayou Goat Mounts
Mopar Online Parts!

Reply
 
Thread Tools
  #1  
Old 09-02-2013, 01:55 AM
Soul Killa's Avatar
Soul Killa Soul Killa is offline
Dodge Ram Forum Member

 
Join Date: Oct 2012
Location: Copperas Cove, TX
Age: 27
Posts: 73
Gender: Male
Vehicle: 2003 Dodge Ram SLT
Trim Level: Beast Mode
Color: Black
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:12
Soul Killa is on a distinguished road
Default Door panels not working?

MY truck is an '03 SLT Fully Loaded, Since ive had the truck as of october 2012, the only way to control the windows up/down is from the drivers door panel. Passengers cannot roll windows down at all. I looked at the door panels and all the wiring looks fine, but cant figure out what is wrong.

Any help would be awsome!
Reply With Quote
Sponsored links
  #2  
Old 09-02-2013, 03:34 AM
RogerRamJet's Avatar
RogerRamJet RogerRamJet is offline
I do it because I can!





 
Join Date: May 2013
Location: Mansfield, TX
Age: 51
Posts: 17,450
Gender: Male
Vehicle: 2014 RAM 1500
Trim Level: Sport 4X4 CC
Color: White
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 16
Rep:2968
RogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond repute
Default

My first thought is you have the lock out button pressed on the drivers door. Make sure that button is not pressed and/or not defective.
__________________
Life is hard... It's harder if you're stupid!
Today is a good day to be a RAM owner!
Reply With Quote
  #3  
Old 09-02-2013, 01:43 PM
HemiLonestar HemiLonestar is offline
Dodge Ram Forum Senior Member
 
Join Date: Nov 2009
Location: MD
Age: 42
Posts: 2,738
Gender: Male
Vehicle: 2003 Dodge Ram 1500 QC
Trim Level: SLT Lonestar Edition
Color: Flame Red
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 8
Rep:280
HemiLonestar is a jewel in the roughHemiLonestar is a jewel in the roughHemiLonestar is a jewel in the rough
Send a message via AIM to HemiLonestar Send a message via MSN to HemiLonestar Send a message via Yahoo to HemiLonestar
Default

Quote:
Originally Posted by RogerRamJet View Post
My first thought is you have the lock out button pressed on the drivers door. Make sure that button is not pressed and/or not defective.
My first thought as well; have you window locked your occupants?
__________________

"Big Red"
2003 Ram 1500 QC Hemi Lonestar Edition (Mods list in profile)
2006 Charger R/T
Sarcasm - it beats killing people
Reply With Quote
  #4  
Old 09-02-2013, 03:02 PM
Revel Performance's Avatar
Revel Performance Revel Performance is offline
REVEL PERFORMANCE

 
Join Date: Sep 2012
Location: lathrop
Posts: 9,540
Gender: Male
Vehicle: MOPAR
Rep Power: 9
Rep:931
Revel Performance is a splendid one to beholdRevel Performance is a splendid one to beholdRevel Performance is a splendid one to beholdRevel Performance is a splendid one to beholdRevel Performance is a splendid one to beholdRevel Performance is a splendid one to beholdRevel Performance is a splendid one to beholdRevel Performance is a splendid one to behold
Default

I had the same problem with my 04. I unhooked the entire switch panel in the drivers door, plugged it back in, and it worked like a charm. I know, not very technical, but it worked for me.
__________________
Contact us via email at
sales@revelperformance.com

Reply With Quote
  #5  
Old 09-02-2013, 04:48 PM
RogerRamJet's Avatar
RogerRamJet RogerRamJet is offline
I do it because I can!





 
Join Date: May 2013
Location: Mansfield, TX
Age: 51
Posts: 17,450
Gender: Male
Vehicle: 2014 RAM 1500
Trim Level: Sport 4X4 CC
Color: White
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 16
Rep:2968
RogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond repute
Default

Quote:
Originally Posted by Bully's Performance View Post
I had the same problem with my 04. I unhooked the entire switch panel in the drivers door, plugged it back in, and it worked like a charm. I know, not very technical, but it worked for me.
If it works... really doesn't matter how technical or why.
__________________
Life is hard... It's harder if you're stupid!
Today is a good day to be a RAM owner!
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement







All times are GMT -4. The time now is 12:33 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
vB.Sponsors