DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 4TH Generation Dodge Ram 2009+ Dodge Ram Trucks > Powertrain > 5.7L (345 cu in) HEMI V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 08-09-2013, 12:15 PM
ramman10 ramman10 is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2013
Location: Washington state
Posts: 3
Gender: Male
Vehicle: 2010 Dodge Ram 1500
Trim Level: SLT Big Horn
Color: Metallic Gray
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
ramman10 is on a distinguished road
Default 2010 Ram Hemi Auto Transmission stuck in 4th gear?

I shifted down to 4th traveling down a long hill and my transmission wouldn't come out of 4th back to 5 and OD. I put it on a reader and said it was a pressure switch/solenoid problem. The truck only has 24K on it and is warranteed I believe. My question is whether this is a common thing with this auto or not. Where are these switches located, in or out of the tranny, also could it just be a fuse? Thanks
Reply With Quote
Sponsored links
  #2  
Old 08-09-2013, 03:56 PM
ArmyofOne's Avatar
ArmyofOne ArmyofOne is offline
US Army Retired


 
Join Date: Dec 2010
Location: Van Alstyne, TX
Age: 29
Posts: 6,104
Gender: Male
Vehicle: '11 Ram 1500 Big Horn Crew 4x4
Trim Level: Big Horn
Color: Brilliant Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 10
Rep:1189
ArmyofOne has much to be proud ofArmyofOne has much to be proud ofArmyofOne has much to be proud ofArmyofOne has much to be proud ofArmyofOne has much to be proud ofArmyofOne has much to be proud ofArmyofOne has much to be proud ofArmyofOne has much to be proud ofArmyofOne has much to be proud of
Default

They are inside the trans, sounds like a trip to dealer. It should be under warranty still. your trans is in 4th gear because it put itself in "limp home" mode. Its the gear that can do the most while causeing the least amount of damage to components and is simply designed to get you off the road and into a parking lot or to your house if you are REALLY close.
__________________
Diesel Technician-PACCAR Inc.
Cummins, PACCAR, CAT, International, Detroit, ASE Certified.

2014 Mazda CX-5 Touring w/Tech Pack-6000K HID's, 20% tint, 35mpg, so I will leave it alone.
2002 Ford Focus ZTW Wagon-loaded, tinted, tunes and commuting. 163k miles and counting...

Reply With Quote
  #3  
Old 08-11-2013, 09:22 PM
ramman10 ramman10 is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2013
Location: Washington state
Posts: 3
Gender: Male
Vehicle: 2010 Dodge Ram 1500
Trim Level: SLT Big Horn
Color: Metallic Gray
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
ramman10 is on a distinguished road
Default Auto stuck in 4th gear

Thanks for the input which is correct. The transmission on these truck stay in 4th gear to get to home or to nearest dealer. I took mine into the dealer, they reset the code, road tested it and I drove it 7 miles and "clunk" back into 4th gear. Next day returned to the dealer with engine light on, with additional problem that my "ECO" light wasn't showing when in "ECO" mode. The senior tech recognized that the solenoid/switch board was bad inside the transmission. The dealer replaced the board, fluid and $1100 charge to Dodge warranty and the problem is gone. Thanks goodness for my warranty. Apparently this problem does occur rarely, but common enough to be recognized by dealer's senior techs. Seems like a design flaw to place a circuit board inside the transmissions, really bad enviornment for electronics. Thanks again for the inputs.
Reply With Quote
  #4  
Old 08-20-2013, 12:59 PM
huntergreen huntergreen is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jan 2011
Location: nj
Posts: 6,107
Gender: Male
Vehicle: 2011 dodge sport 1500 hemi
Trim Level: sport
Color: green
Engine: 2009-2010 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 8
Rep:636
huntergreen is a name known to allhuntergreen is a name known to allhuntergreen is a name known to allhuntergreen is a name known to allhuntergreen is a name known to allhuntergreen is a name known to all
Default

glad they got you up and running without too much of an issue.
Reply With Quote
  #5  
Old 09-12-2013, 05:36 PM
Hammahamma Hammahamma is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2013
Location: Washington
Posts: 4
Gender: Male
Vehicle: 2010 Ram 1500
Color: Blue
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Hammahamma is on a distinguished road
Default Stuck in 4th gear

Same thing happened to me. I was towing a small trailer, less then 5000lbs from GNP when the transmission shifted out of tow mode and into 4th gear. Limped into Steamboat Rock SP then home. Took it to dealer and they replaced a solenoid/sensors in the transmission and changed fluid. Truck had just under 15K miles on it. Been driving the truck a week and so far so good. However, when the transmission went bad, I also lost indicators on my dash, i.e., when I shift into reverse The "R" is not lighting up on the dash and same goes with "D" for drive. It did prior to the truck's transmission issues. Both issues reared it's ugly head at the same time. Brought the truck in today and dealer couldn't fix and doesn't know what is causing the problem. They shut down the electronic brains and did a restart, plus was on the phone with corporate but they had no answers. They think it may be another plug and play black box which they are ordering. They can't guarantee this will be the fix. Anybody out there have this same problem? Any ideas?
Reply With Quote
  #6  
Old 09-13-2013, 11:53 AM
TexasRam TexasRam is offline
Dodge Ram Forum Newcomer
 
Join Date: Apr 2012
Location: Texas
Age: 25
Posts: 11
Gender: Male
Vehicle: 2010 Dodge Ram
Trim Level: slt
Color: White
Engine: 2008-20?? 287ci (4.7L) PowerTech V8 310hp 330lb/ft
Rep Power: 0
Rep:10
TexasRam is on a distinguished road
Default

This is why i love my 4.7
Reply With Quote
  #7  
Old 09-18-2013, 09:18 AM
TransEngineer TransEngineer is offline
Dodge Ram Forum Senior Member!
 
Join Date: Nov 2011
Location: Grass Lake, MI
Posts: 1,211
Gender: Male
Vehicle: N/A
Rep Power: 4
Rep:350
TransEngineer is just really niceTransEngineer is just really niceTransEngineer is just really niceTransEngineer is just really nice
Default

Quote:
Originally Posted by Hammahamma View Post
... However, when the transmission went bad, I also lost indicators on my dash, i.e., when I shift into reverse The "R" is not lighting up on the dash and same goes with "D" for drive. It did prior to the truck's transmission issues. Both issues reared it's ugly head at the same time. ...
So what do you see on your dash? I think on yours the PRND letters are normally white, but the current gear position displays as green (or red for Reverse). So P and N are OK? Do you have a P0706 fault code?

If no P0706 fault, then I suspect the problem is in the instrument cluster and not the trans. If the trans itself is sending a "bad" (invalid) PRND position code, the dash display should light up ALL the positions (which, because of how the display is set up, looks like Reverse, because P, N, and D are all green but R is red).
Reply With Quote
  #8  
Old 09-23-2013, 12:00 AM
Hammahamma Hammahamma is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2013
Location: Washington
Posts: 4
Gender: Male
Vehicle: 2010 Ram 1500
Color: Blue
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Hammahamma is on a distinguished road
Default

TransEngineer, Thanks for your response. The problems started when towing. The dealer fixed the transmission issues hopefully. I guess time will tell. About the indicators: I am referring to the three small windows of the cluster right below the odometer. Before my transmission went out I use to register an R for reverse in the far left and a D in the far right window when in drive. When in cruise control, the far right window lights up or when I use tow haul the far right window lights up in 5 as in 5th gear. When I toggle (+) or (-) on the column shift lever I see 1-2-3-4-5-and I am also suppose to see the "D" for drive if toggled one more time (PG 305 of owners manual). Bottom line is I am not seeing my "R" or "D" when I shift. The dealer said he doesn't know why and don't know how to fix it but it's not covered and it is what it is. It may sound minor but What else isn't working that should? Will I not see a warning when I should? the dealer had no answer for me. Any ideas??? THanks,
Hamma
Reply With Quote
  #9  
Old 09-23-2013, 08:52 AM
TransEngineer TransEngineer is offline
Dodge Ram Forum Senior Member!
 
Join Date: Nov 2011
Location: Grass Lake, MI
Posts: 1,211
Gender: Male
Vehicle: N/A
Rep Power: 4
Rep:350
TransEngineer is just really niceTransEngineer is just really niceTransEngineer is just really niceTransEngineer is just really nice
Default

If the trans is functioning correctly and you have no P0706 fault, then I would think the problem is within the cluster itself. That is, the PCM is correctly telling the cluster what to display, but the cluster is not doing it.
Reply With Quote
  #10  
Old 09-23-2013, 05:37 PM
Hammahamma Hammahamma is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2013
Location: Washington
Posts: 4
Gender: Male
Vehicle: 2010 Ram 1500
Color: Blue
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Hammahamma is on a distinguished road
Default

Thanks for your input. Appreciate your help.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 01:50 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum