DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Electrical


Notices

Electrical 2nd Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 08-02-2013, 06:32 PM
CB56 CB56 is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2012
Location: W.PA
Posts: 10
Gender: Male
Vehicle: 2000 Dodge Ram 2500
Trim Level: Laramie SLT
Color: Silver
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
CB56 is on a distinguished road
Default no bus. Can someone explain this?

One day I start the truck and I have no gauges working. I go for a drive and it runs good and there is no tachometer or speedometer. Where the odometer is there are no numbers but it says no bus. No fuses are blown. The overhead info. display only shows ccd.
2000 MY, 2500 SLT Lariat, four door, long bed, RWD, 360 cu. in. gasoline motor, auto. trans., 85,000 miles. The engine icon and the abs and the airbag lights are on in the instrument cluster. Today I had a diagnostic check done and there are no codes thrown. Help will be appreciated. CB

Last edited by CB56; 08-02-2013 at 06:37 PM. Reason: Added more info.
Reply With Quote
Sponsored links
  #2  
Old 08-02-2013, 07:15 PM
Warlock III Warlock III is offline
Former Senior Member
 
Join Date: Aug 2010
Location: Earth...DUH!
Posts: 7,868
Gender: Male
Vehicle: 95
Trim Level: Cloaking
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 11
Rep:1776
Warlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant future
Send a message via AIM to Warlock III Send a message via Yahoo to Warlock III
Default

It sounds to me like the solder connections on the back of the speedometer are cracked, and no info is travelling up the spinal cord to the brain, so to speak.

Here's a thread where a member didn't care to listen for a few days and then finally did. I'm not 100% sure it's your problem, but I have seen it before on these trucks.

http://www.ramforumz.com/showthread.php?t=141037

Pull the speedo and check the connections.

Some Rams experience this as well as the older Caravans, Voyagers, Mitsubishi, Eagles etc..

No Bus=No communication. It may just as well say "Duh" and be drooling on itself. Stupid term but hey, that's what it is. Bus is the term used between the computers on your truck. No bus, no communication. It could be a fuse but I doubt it. You'd have found that long ago. Your PCM is unable to communicate and a severed spinal column is a good reason for the brain (Speedo cluster) won't do what it's told. Try wiggling the face of the cluster and see what it does, it might make a connection.


Is that an acceptable explanation?

Last edited by Warlock III; 08-02-2013 at 07:46 PM.
Reply With Quote
  #3  
Old 08-02-2013, 08:02 PM
RansRAM's Avatar
RansRAM RansRAM is online now
Addicted to the Z


 
Join Date: Feb 2010
Location: Mississauga, Ontario, Canada
Age: 55
Posts: 12,535
Gender: Male
Vehicle: 2014 RAM 1500 Limited
Trim Level: Crew Cab 4X4 Limited
Color: PX8 Black
Engine: 2014-20?? 182.3ci (3.0L) L630DOHC V6 240hp 420lb/ft Eco-Diesel
Rep Power: 15
Rep:2471
RansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond repute
Thumbs up

Quote:
Originally Posted by Warlock III View Post
It sounds to me like the solder connections on the back of the speedometer are cracked, and no info is travelling up the spinal cord to the brain, so to speak.

Here's a thread where a member didn't care to listen for a few days and then finally did. I'm not 100% sure it's your problem, but I have seen it before on these trucks.

http://www.ramforumz.com/showthread.php?t=141037

Pull the speedo and check the connections.

Some Rams experience this as well as the older Caravans, Voyagers, Mitsubishi, Eagles etc..

No Bus=No communication. It may just as well say "Duh" and be drooling on itself. Stupid term but hey, that's what it is. Bus is the term used between the computers on your truck. No bus, no communication. It could be a fuse but I doubt it. You'd have found that long ago. Your PCM is unable to communicate and a severed spinal column is a good reason for the brain (Speedo cluster) won't do what it's told. Try wiggling the face of the cluster and see what it does, it might make a connection.


Is that an acceptable explanation?
^^^^ Great explanation and analogy
__________________
New Signature Pic Pending
Shorty Antenna, Recon 3rd Brake & Xtreme LightBar, DeeZee Tailgate Assist, MOPAR Valve Caps, Lighted RAM hitch cover, Tints (20% frt),Bug deflector, LED Interior Lights,.
Reply With Quote
  #4  
Old 08-02-2013, 08:57 PM
CB56 CB56 is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2012
Location: W.PA
Posts: 10
Gender: Male
Vehicle: 2000 Dodge Ram 2500
Trim Level: Laramie SLT
Color: Silver
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
CB56 is on a distinguished road
Default

Yes and thank you. I kind of figured bus means power as in a bus bar in breaker panels. CB
Reply With Quote
  #5  
Old 08-02-2013, 09:21 PM
RansRAM's Avatar
RansRAM RansRAM is online now
Addicted to the Z


 
Join Date: Feb 2010
Location: Mississauga, Ontario, Canada
Age: 55
Posts: 12,535
Gender: Male
Vehicle: 2014 RAM 1500 Limited
Trim Level: Crew Cab 4X4 Limited
Color: PX8 Black
Engine: 2014-20?? 182.3ci (3.0L) L630DOHC V6 240hp 420lb/ft Eco-Diesel
Rep Power: 15
Rep:2471
RansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond reputeRansRAM has a reputation beyond repute
Default

Either one of the modules on the bus is defective (like the cluster itself) or the connections between them is loose or there is some corrosion. The thing about the data bus on these vehicles (aka the CAN Bus) is that there is no type of error checking, essentially it is send and pray between modules. So everything electrical between them needs to be perfect.
__________________
New Signature Pic Pending
Shorty Antenna, Recon 3rd Brake & Xtreme LightBar, DeeZee Tailgate Assist, MOPAR Valve Caps, Lighted RAM hitch cover, Tints (20% frt),Bug deflector, LED Interior Lights,.
Reply With Quote
  #6  
Old 08-02-2013, 11:49 PM
CB56 CB56 is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2012
Location: W.PA
Posts: 10
Gender: Male
Vehicle: 2000 Dodge Ram 2500
Trim Level: Laramie SLT
Color: Silver
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
CB56 is on a distinguished road
Default

It would be perfect if this sumbitch had a new owner. CB
Reply With Quote
  #7  
Old 09-13-2013, 12:02 AM
Fatherholyholy Fatherholyholy is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2013
Posts: 4
Gender: Male
Vehicle: 2001
Rep Power: 0
Rep:10
Fatherholyholy is on a distinguished road
Default

I had the same problem about 4 years ago. Lost all guages for about 3 months. Got one ticket and got out of it when I showed the cop. I wish I could tell you what I did to fix it but the dang thing fixed itself... until now.

From my research, the no bus signal means a networking problem between the computers. This means that any sensor in the loop, frayed wiring or the actual computers themselves could be the culprits. Unfortunately, there are a shiton of them that are all looped in.

You can check the dashboard connections but before doing that, I'd suggest checking the wiring plugs going to the PCM on the left passenger side on the firewall and the plug going into the ecm behind the battery driver's side (take the cover off and look for the plug with the screw in the center) and the BCM located on the left behind the parking brake. Remove neg batt cable then remove the connectors. Make sure there is no broken wires or corrosion (usually green)on the pins. If there is, clean them. Use some dielectrical grease and plug them back in. Turn the key to the on position for 10 seconds or so with the neg. cable still removed(i'm told this resets the PCM). Return the neg. cable and see what happens.

If that doesn't fix it, I'd pull the guage cluster to check connection or begin testing the sensors for a short. I'm told the camshaft sensor is one of the most common failure points. Try that first. What sucks is even a short in a completely unrelated area (such as the radio wiring) could cause a No Bus signal.

Good luck.

Last edited by Fatherholyholy; 09-13-2013 at 12:07 AM.
Reply With Quote
  #8  
Old 09-13-2013, 12:12 AM
GTyankee's Avatar
GTyankee GTyankee is offline
Dodge Ram Forum Member

 
Join Date: Dec 2009
Location: San Diego East County, Ca
Posts: 19,112
Gender: Male
Vehicle: 2009 Dodge Ram 1500 2X4
Trim Level: quad cab SLT
Color: sunburst orange pearl
Rep Power: 20
Rep:2615
GTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond repute
Default

you may want to read a few of these

https://www.google.com/search?q=dodg...l=np&source=hp
__________________
Ram 1500 SLT Quad cab, 5.7 HEMI(R) MDS VCT, 5 speed auto 545RFE, 3.55 differential gears, 18" Magnaflow muffler, EGR bug deflector, Bushwacker fender flares, customized Nfab nerf bars, CB radio, Autonet wi-fi router, custom soft tonneau cover, Line_X bedliner, DEBO Step, build date 10/15/08 a Wednesday built vehicle
Reply With Quote
  #9  
Old 09-13-2013, 01:07 AM
RogerRamJet's Avatar
RogerRamJet RogerRamJet is offline
God Bless Texas!




 
Join Date: May 2013
Location: Mansfield, TX
Age: 50
Posts: 11,586
Gender: Male
Vehicle: 2005 Ram 1500
Trim Level: Lonestar QC
Color: White
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 12
Rep:2929
RogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond repute
Default

Thanks Drew! Gonna tuck that little tidbit of info away for later.
__________________
Life is hard... It's harder if you're stupid!
Today is a good day to be a RAM owner!
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 09:19 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum