DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Mod Zone - Custom Dodge Ram Mods - Dodge Ram Performance > Custom Dodge Ram Interior and Exterior Lighting


Notices

Custom Dodge Ram Interior and Exterior Lighting HID - HALO - LED LIGHTING - UNDERBODY LIGHTING - TINTED/SMOKED/PAINTED TAILS - ETC.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 09-14-2013, 09:48 AM
DatacomGuy DatacomGuy is offline
Dodge Ram Forum Member
 
Join Date: Jun 2013
Location: Atlanta, GA
Posts: 64
Gender: Male
Vehicle: 2013 Dodge Ram
Trim Level: Express
Color: Mineral Gray
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
DatacomGuy is on a distinguished road
Default *Installing now* HIDs wont light up?

Installing HIDs.. 55w ballasts, H11 bulbs, Error code eliminators.. Everything wires up but neither side will power up. Truck running or not.

I've reversed polarity at the bulb side, ive tried removing the eliminators, and i've even tried some 35w ballasts i have laying around, and nothing is working.

Im missing something, just can't put a finger on it. Thoughts?
__________________
2013 1500 CC | Mineral Gray | Hemi 5.7 | 3.55 LSD | 15% | Dip'd Badges | 4" AirBox CAI | Cut Antenna
Reply With Quote
Sponsored links
  #2  
Old 09-14-2013, 10:10 AM
Asur Asur is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2012
Posts: 6,850
Gender: Male
Vehicle: .
Rep Power: 14
Rep:4364
Asur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond repute
Default

First, what kind of kit did you get, did you order it with a wire harness? is this kit specific for the 2013 Ram 1500? Did you test it outside the truck before installing it? if you take the ballast and bulb and plug it direct to the battery does it light up? you say you had a 35watt kit laying around so I am presuming this is not the first time your installing HID's on a vehicle.
Reply With Quote
  #3  
Old 09-14-2013, 10:17 AM
DatacomGuy DatacomGuy is offline
Dodge Ram Forum Member
 
Join Date: Jun 2013
Location: Atlanta, GA
Posts: 64
Gender: Male
Vehicle: 2013 Dodge Ram
Trim Level: Express
Color: Mineral Gray
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
DatacomGuy is on a distinguished road
Default

DDM 55w kit. No harness, using factory wiring. Read all over here that most people were having success with PnP so i figured i'd have no issues.
__________________
2013 1500 CC | Mineral Gray | Hemi 5.7 | 3.55 LSD | 15% | Dip'd Badges | 4" AirBox CAI | Cut Antenna
Reply With Quote
  #4  
Old 09-14-2013, 10:25 AM
Asur Asur is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2012
Posts: 6,850
Gender: Male
Vehicle: .
Rep Power: 14
Rep:4364
Asur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond repute
Default

Quote:
Originally Posted by DatacomGuy View Post
DDM 55w kit. No harness, using factory wiring. Read all over here that most people were having success with PnP so i figured i'd have no issues.
I myself after 15 years of using HID's in all my vehicles I prefer using a wire harness, no chance of screwing up the BCM or light controllers, I have even seen some there light switches have blown, 55watt HID's pull about 10amps when powering on, then they fall to .something when lite. Anyways, that does not solve your problem, does your ballast and bulb trigger when plugged to the battery direct? If you plug your halogen bulb back in does it light up when you turn your lights on?
Reply With Quote
  #5  
Old 09-14-2013, 10:34 AM
DatacomGuy DatacomGuy is offline
Dodge Ram Forum Member
 
Join Date: Jun 2013
Location: Atlanta, GA
Posts: 64
Gender: Male
Vehicle: 2013 Dodge Ram
Trim Level: Express
Color: Mineral Gray
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
DatacomGuy is on a distinguished road
Default

Halogen lights up fine when plugged back in.

Without a harness, i have no way to connect direct to battery.
__________________
2013 1500 CC | Mineral Gray | Hemi 5.7 | 3.55 LSD | 15% | Dip'd Badges | 4" AirBox CAI | Cut Antenna
Reply With Quote
  #6  
Old 09-14-2013, 11:39 AM
Asur Asur is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2012
Posts: 6,850
Gender: Male
Vehicle: .
Rep Power: 14
Rep:4364
Asur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond repute
Default

Quote:
Originally Posted by DatacomGuy View Post
Halogen lights up fine when plugged back in.

Without a harness, i have no way to connect direct to battery.
True, you would need a plug that has 2 wires to it, you can find those at your local pep boys or napa parts place. I would test my HID's outside the truck first or on the battery direct, since your halogens are working fine, put those in and your good, nothing is blown, once you know your HID kit is working well outside the truck, then get it installed. I have read some others have no issues with DDM so you might have 2 locked ballasts or something. Like I said, best to test direct to see. I would also suggest you get a wire harness, its more work but your better off. If you do go that route, get a good one with all the caps and resistors, also get one made for your truck, check out retrosolutions or theretrofitsource. This again is JMO
Reply With Quote
  #7  
Old 09-14-2013, 12:33 PM
DatacomGuy DatacomGuy is offline
Dodge Ram Forum Member
 
Join Date: Jun 2013
Location: Atlanta, GA
Posts: 64
Gender: Male
Vehicle: 2013 Dodge Ram
Trim Level: Express
Color: Mineral Gray
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
DatacomGuy is on a distinguished road
Default

I tried a 35w ballast that i know works, and no dice for that one also.

I think harness is the fix
__________________
2013 1500 CC | Mineral Gray | Hemi 5.7 | 3.55 LSD | 15% | Dip'd Badges | 4" AirBox CAI | Cut Antenna
Reply With Quote
  #8  
Old 09-14-2013, 12:41 PM
Asur Asur is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2012
Posts: 6,850
Gender: Male
Vehicle: .
Rep Power: 14
Rep:4364
Asur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond repute
Default

Quote:
Originally Posted by DatacomGuy View Post
I tried a 35w ballast that i know works, and no dice for that one also.

I think harness is the fix
Agree, would still like to confirm that all the ballasts your installing are good. 2$ plug and wire would prove that.
Reply With Quote
  #9  
Old 09-15-2013, 08:44 AM
gcscott's Avatar
gcscott gcscott is offline
Dodge Ram Forum Senior Member!
 
Join Date: Apr 2013
Location: North of Pittsburgh, PA
Age: 56
Posts: 958
Gender: Male
Vehicle: 2013 Ram 1500 4X4 / 3.55 LSD
Trim Level: Outdoorsman Crew Cab
Color: Deep Cherry Red Crystal Pearl Coat
Engine: 2013-20?? 220ci (3.6L) Pentastar 305hp 269lb/ft
Rep Power: 4
Rep:1043
gcscott has much to be proud ofgcscott has much to be proud ofgcscott has much to be proud ofgcscott has much to be proud ofgcscott has much to be proud ofgcscott has much to be proud ofgcscott has much to be proud ofgcscott has much to be proud of
Default

If you connect the ballast directly to the battery using jumper wire and the bulbs lights up and does not flicker. Than you know that part works correctly. When you connect it with the factory wiring and get nothing or flickering you need to get a wiring harness. You do not have enough power coming through the factory wiring to light off the ballast.

I put 35 watt DDM Tuning fog light HID's in mine and I had to use a wiring harness to get the bulbs to work. Factory wiring didn't have enough power to fire the ballast.

Greg
__________________
MOD LIST:To many to list. I do all MODS and Installs myself.
View them here: http://www.ramforumz.com/member.php?u=66037
Every time I think I'm done with doing Mods something else catches my eye.


Last edited by gcscott; 09-15-2013 at 08:51 AM.
Reply With Quote
  #10  
Old 09-24-2013, 09:26 PM
DatacomGuy DatacomGuy is offline
Dodge Ram Forum Member
 
Join Date: Jun 2013
Location: Atlanta, GA
Posts: 64
Gender: Male
Vehicle: 2013 Dodge Ram
Trim Level: Express
Color: Mineral Gray
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
DatacomGuy is on a distinguished road
Default

Quote:
Originally Posted by gcscott View Post
If you connect the ballast directly to the battery using jumper wire and the bulbs lights up and does not flicker. Than you know that part works correctly. When you connect it with the factory wiring and get nothing or flickering you need to get a wiring harness. You do not have enough power coming through the factory wiring to light off the ballast.

I put 35 watt DDM Tuning fog light HID's in mine and I had to use a wiring harness to get the bulbs to work. Factory wiring didn't have enough power to fire the ballast.

Greg
So you needed a wiring harness for the fogs too?
__________________
2013 1500 CC | Mineral Gray | Hemi 5.7 | 3.55 LSD | 15% | Dip'd Badges | 4" AirBox CAI | Cut Antenna
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 06:49 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum