DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - General Discussion > 2013 Dodge Ram Forum


Notices

2013 Dodge Ram Forum For specific discussion of the 2013 Dodge Ram!


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 09-16-2013, 12:22 AM
shaverlake's Avatar
shaverlake shaverlake is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2013
Location: california
Posts: 7
Gender: Male
Vehicle: 2013 ram 1500
Trim Level: laramie
Color: red
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
shaverlake is on a distinguished road
Default Radio Failure

Just lost all functions of the radio, display, and all electronics on my 3 week old 2013 1500 Laramie with less than 500 miles. Dealer states that the entire radio system will be replaced. Will be without truck for at least three weeks. Anyone else had this problem? Problems started after LOJack was installed. Needless to say this does not give me much faith on my purchase.
Reply With Quote
Sponsored links
  #2  
Old 09-16-2013, 07:30 AM
plumcrazy73's Avatar
plumcrazy73 plumcrazy73 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Feb 2010
Location: Fort Benning Ga Area
Posts: 574
Gender: Male
Vehicle: 2013 Ram 1500 2WD Crew Cab
Trim Level: SLT w/Big Horn EQ GP
Color: True Blue Pearl
Engine: 2013-20?? 220ci (3.6L) Pentastar 305hp 269lb/ft
Rep Power: 5
Rep:119
plumcrazy73 will become famous soon enoughplumcrazy73 will become famous soon enough
Default

tell them to order the radio and drive the truck till the new radio comes in
Reply With Quote
  #3  
Old 09-16-2013, 10:46 AM
tev9999 tev9999 is offline
Dodge Ram Forum Senior Member!
 
Join Date: May 2013
Posts: 351
Gender: Male
Vehicle: 2013 Ram 1500
Trim Level: Outdoorsman
Color: Maximum Steel
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:39
tev9999 is on a distinguished road
Default

Have you tried rebooting the radio by holding both the power and selection buttons in for ~10 seconds? Mine failed to start for the first time over the weekend. Holding both buttons had it running again in seconds. The only thing I had to reset was the clock.
Reply With Quote
  #4  
Old 09-16-2013, 12:00 PM
Shreve T's Avatar
Shreve T Shreve T is offline
Dodge Ram Forum Senior Member!
 
Join Date: Sep 2010
Location: Shreveport,LA
Age: 50
Posts: 99
Gender: Male
Vehicle: 2013 black Gold
Trim Level: Larime Longhorn
Rep Power: 0
Rep:27
Shreve T is on a distinguished road
Default

Quote:
Originally Posted by shaverlake View Post
Just lost all functions of the radio, display, and all electronics on my 3 week old 2013 1500 Laramie with less than 500 miles. Dealer states that the entire radio system will be replaced. Will be without truck for at least three weeks. Anyone else had this problem? Problems started after LOJack was installed. Needless to say this does not give me much faith on my purchase.

Much faith on the purchase of the "LOJack" ?? This by no means could be the fault of Ram IMO
Reply With Quote
  #5  
Old 09-16-2013, 12:09 PM
SoCalExpress SoCalExpress is offline
Dodge Ram Forum Member
 
Join Date: Jul 2013
Location: Southern California
Posts: 232
Gender: Male
Vehicle: 2013 Express Quad Cab
Trim Level: Express QC Rwd
Color: Mineral Gray
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 2
Rep:108
SoCalExpress will become famous soon enoughSoCalExpress will become famous soon enough
Default

Quote:
Originally Posted by Shreve T View Post
Much faith on the purchase of the "LOJack" ?? This by no means could be the fault of Ram IMO
I agree. Sunds like someone tried to do a job over their pay grade/know how and screwed up.

BTW Shaverlake I was just camping up in your area (lake Edison) and its gorgeous up there, only been a week and I miss it already.
__________________
Custom Header Back SS true Dual Exhaust with 2 22" Maggys, De-Badged sides and blacked out tailgate emblem, Tonno Pro tri fold cover, Fold forward rear seat (extra storage is great!)
Pictures - http://s1090.photobucket.com/user/pa.../library/Truck
Reply With Quote
  #6  
Old 09-16-2013, 09:30 PM
BCLII BCLII is offline
Dodge Ram Forum Junior Member
 
Join Date: Sep 2013
Location: MN
Age: 57
Posts: 33
Gender: Male
Vehicle: 2014 Ram 1500
Trim Level: Outdoorsman
Color: Granite Crystal
Engine: 2014-20?? 182.3ci (3.0L) L630DOHC V6 240hp 420lb/ft Eco-Diesel
Rep Power: 0
Rep:10
BCLII is on a distinguished road
Default

Quote:
Originally Posted by shaverlake View Post
Just lost all functions of the radio, display, and all electronics on my 3 week old 2013 1500 Laramie with less than 500 miles. Dealer states that the entire radio system will be replaced. Will be without truck for at least three weeks. Anyone else had this problem? Problems started after LOJack was installed. Needless to say this does not give me much faith on my purchase.
LOJack? What is this?
Reply With Quote
  #7  
Old 09-27-2013, 01:39 AM
shaverlake's Avatar
shaverlake shaverlake is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2013
Location: california
Posts: 7
Gender: Male
Vehicle: 2013 ram 1500
Trim Level: laramie
Color: red
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
shaverlake is on a distinguished road
Default

After two and a half weeks at the dealer they finally decided to listen to me and found that when the LoJack (sat. theft detection system) was installed it was connected to backup camera which shorted the camera and radio system. I had told them to check this on day 1----Sad part was that the dealer never took ownership on missing the call in the first place. Good part is that it wasn't the fault of RAM but a aftermarket install.
Reply With Quote
  #8  
Old 09-27-2013, 04:39 AM
GTyankee's Avatar
GTyankee GTyankee is offline
Dodge Ram Forum Member

 
Join Date: Dec 2009
Location: San Diego East County, Ca
Posts: 19,044
Gender: Male
Vehicle: 2009 Dodge Ram 1500 2X4
Trim Level: quad cab SLT
Color: sunburst orange pearl
Rep Power: 20
Rep:2615
GTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond repute
Default

I would not trust the Ram security system either
a Lojack or even better a Ravelco device is much better
__________________
Ram 1500 SLT Quad cab, 5.7 HEMI(R) MDS VCT, 5 speed auto 545RFE, 3.55 differential gears, 18" Magnaflow muffler, EGR bug deflector, Bushwacker fender flares, customized Nfab nerf bars, CB radio, Autonet wi-fi router, custom soft tonneau cover, Line_X bedliner, DEBO Step, build date 10/15/08 a Wednesday built vehicle
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 08:11 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum