DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Powertrain > V10 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #21  
Old 02-07-2013, 10:12 AM
gunfighter's Avatar
gunfighter gunfighter is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2011
Location: Hubert NC
Age: 41
Posts: 19
Gender: Male
Vehicle: 2001 Ram 2500
Trim Level: ST
Color: White
Engine: 1994-2001 488ci (8.0L) LA V10 300 hp 450lb/ft
Rep Power: 0
Rep:10
gunfighter is on a distinguished road
Default

Mine was acting funky for awhile, similar problem, Would run ok most of the time and then out of the blue would just fall on it's face. Had to pull the cats, one went bad. FTR without the cats the truck runs like a scalded ape, it'll eat 35" tires without issue now, could never do that before. My culprit was the spark plugs, worn out, not gapped properly, once I changed them out it never did it again, about 1500 miles so far.
Reply With Quote
  #22  
Old 03-24-2013, 01:16 AM
Big Bob Big Bob is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2011
Location: Buckeye AZ
Posts: 15
Gender: Male
Vehicle: 1995 Dodge Ram 2500
Trim Level: SLT Laramie
Color: White
Engine: 1994-2001 488ci (8.0L) LA V10 300 hp 450lb/ft
Rep Power: 0
Rep:10
Big Bob is on a distinguished road
Default

Ok, after a couple of months screwing around with this, I have finally fixed the problem. It was just two weeks ago when I put two and two together and had a brainstorm that may or may not have worked.
Essentially all operating parameters are pre-determined until the engine is warmed to normal operating temp. At that point the PCM takes over, this may be over simplified, but this is how I understand it.
My engine ran fine until it got to normal operating temp, hence the PCM was running the show, something must be wrong the PCM. I found a used one in Montana for $125.00, bought it and had it shipped to me. It took about 5 minutes to swap out with the old one, with one small back fire the engine fired up, and is now running fine. I did have a 13 code (MAP sensor), I took that out, cleaned it up and the code is now gone.
However (it seems there is always a however) my maintenance required light is on, I have no idea why. The only code I get is 12, because I had the battery disconnected to try and clear the 13 after I cleaned it.
Does anybody have any ideas as to what the light represents or how to get rid of it. It is not reassuring while I'm driving.
Reply With Quote
  #23  
Old 03-27-2013, 10:45 PM
99 V10 99 V10 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Nov 2012
Posts: 110
Gender: Male
Vehicle: 1996 SLT
Trim Level: SLT
Engine: 1994-2001 488ci (8.0L) LA V10 300 hp 450lb/ft
Rep Power: 0
Rep:10
99 V10 is on a distinguished road
Default

Glad you got it fixed. My guess a code reader is going to have to clear the light or you still have an issue.
Reply With Quote
  #24  
Old 06-10-2013, 11:12 PM
Pman's Avatar
Pman Pman is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2013
Location: Washington
Posts: 22
Gender: Male
Vehicle: 1996 Dodge Ram 3500 Dually V10
Trim Level: SLT
Color: White
Engine: 2003-2003 488ci (8.0L) Magnum V10 310hp 450lb/ft
Rep Power: 0
Rep:10
Pman is on a distinguished road
Default

You might need to have your ECM flashed? They (the dealer here) said I would need to do that if I installed a new one. Not even sure what "flash" is. Sorry, I'm new and surfing for potential issues, fixes and upgrades.
Reply With Quote
  #25  
Old 06-11-2013, 12:19 AM
Pman's Avatar
Pman Pman is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2013
Location: Washington
Posts: 22
Gender: Male
Vehicle: 1996 Dodge Ram 3500 Dually V10
Trim Level: SLT
Color: White
Engine: 2003-2003 488ci (8.0L) Magnum V10 310hp 450lb/ft
Rep Power: 0
Rep:10
Pman is on a distinguished road
Default

Found this and it may be worth checking out.

http://dodgeram.info/tsb/1998/18-16-98.htm
Reply With Quote
  #26  
Old 10-17-2013, 01:15 AM
northern2002's Avatar
northern2002 northern2002 is offline
Dodge Ram Forum Newcomer
 
Join Date: May 2013
Location: unalaska,ak
Posts: 28
Gender: Male
Vehicle: 2002 dodge ram 2500
Trim Level: SLT plus
Color: gray
Engine: 1994-2001 488ci (8.0L) LA V10 300 hp 450lb/ft
Rep Power: 0
Rep:10
northern2002 is on a distinguished road
Default

check your plugs see which ones are wet wih fuel chances are you will need the heads redone i have two V10 trucks and its the heads valve issue.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 09:42 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum