DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - General Discussion > 2010 Dodge Ram Forum


Notices

2010 Dodge Ram Forum For specific discussion of the new 2010 Dodge Ram!


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 10-22-2013, 10:18 PM
BigT BigT is offline
Dodge Ram Forum Senior Member!
 
Join Date: Nov 2009
Location: Danvers, MA
Age: 36
Posts: 82
Gender: Male
Vehicle: 2014 Ram 1500
Trim Level: Limited
Color: Black
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 0
Rep:10
BigT is on a distinguished road
Default MPG Drop

So I have a 2010 Big Horn and my mpg has been pretty consistent since I bought it new 3 years ago but has dropped in the past month or so. I got new tires a few months ago and Jiffy Lube did my most recent oil change but nothing else has changed as far as I can tell. Anyone else having an issue or any ideas of what's going on? I was averaging about 16 and now I'm down to 14.
Reply With Quote
Sponsored links
  #2  
Old 10-22-2013, 10:36 PM
Gantman's Avatar
Gantman Gantman is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2012
Location: Ram Country
Age: 45
Posts: 1,963
Gender: Male
Vehicle: 2014 4x4 Regular Cab w/8ft bed
Trim Level: Tradesman 4x4
Color: White
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 4
Rep:974
Gantman is a splendid one to beholdGantman is a splendid one to beholdGantman is a splendid one to beholdGantman is a splendid one to beholdGantman is a splendid one to beholdGantman is a splendid one to beholdGantman is a splendid one to beholdGantman is a splendid one to behold
Default

Did JiffyLube use 5W20 in your Hemi? If you're over 30,000 miles, have you changed the plugs? It could be as simple as fuel stations change in blend of fuel too. Just some things throwin out for thought bud.
__________________
Reply With Quote
  #3  
Old 10-22-2013, 10:54 PM
Asur Asur is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2012
Posts: 6,850
Gender: Male
Vehicle: .
Rep Power: 14
Rep:4371
Asur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond reputeAsur has a reputation beyond repute
Default

Agree with Gantman, if Jiffy put in something other than 5w20 you will find it will not run very well either MDS does not like anything else. As Gantman said, air Filter, plugs, crappy gas, all of these may be a contributor. What kind of tires did you put on.
Reply With Quote
  #4  
Old 10-23-2013, 10:49 AM
rockdoc's Avatar
rockdoc rockdoc is offline
Dodge Ram Forum Member
 
Join Date: Feb 2010
Location: High River Alberta
Age: 61
Posts: 65
Gender: Male
Vehicle: 2010 Dodge Laramie Hemi
Trim Level: Laramie
Color: Grey with silver trim
Engine: 2009-2010 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
rockdoc is on a distinguished road
Default

Well there ya go. I have, surprisingly, the opposite happening. Have done nothing new and aside from valve guide seals failure, and as of this A.M. 127,000kms on "Ole Smokey" getting solid 20s' on cruise at 110-120kms per hour?. This on 6 1800+ trips. These trucks confuse me. I did notice mileage increasing slightly with the new plugs at 80,000kms. Good hunting.
Reply With Quote
  #5  
Old 10-23-2013, 06:52 PM
BigT BigT is offline
Dodge Ram Forum Senior Member!
 
Join Date: Nov 2009
Location: Danvers, MA
Age: 36
Posts: 82
Gender: Male
Vehicle: 2014 Ram 1500
Trim Level: Limited
Color: Black
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 0
Rep:10
BigT is on a distinguished road
Default

They said they used 5w20 and I made point of it. Also I watched them change the oil and they definitely used what was supposed to be 5w20 but I didn't see the original source. I got Bridgestone - Dueler H/L Alenza tires and I did get the plugs changed at 30k. I've been getting gas at the same stations so that shouldn't be the issue. I might just change the oil myself and see if it changes things. Thanks for the suggestions and keep em coming if anyone else is seeing an mpg drop after 50k miles.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 09:27 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum