DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 4TH Generation Dodge Ram 2009+ Dodge Ram Trucks > Electrical
Register Advertising Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read


Notices

Electrical 4th Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 12-03-2013, 02:48 PM
511gtx69 511gtx69 is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2013
Location: 1000 islands ny
Age: 71
Posts: 27
Gender: Male
Vehicle: 2011 dodge ram
Trim Level: outdoor
Color: w/g
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
511gtx69 is on a distinguished road
Default Plow on my Ram looses power?

Put a Western HTS plow on my 2011 outdoorsman 1500. Every once in a while my plow and head lights loose power completely. Wait a few minutes and it comes back on, like a breaker that resets. Not a fuse. Called my dealer and confirmed red wire to accessory wire under dash. pink-white - ignition node on key cylinder. Checked all connections and fuses. The dealer that installed the new plow is 2 hours away so I want to trouble shoot this myself if I can.

thanks 511
Reply With Quote
Sponsored links
  #2  
Old 12-03-2013, 03:55 PM
namretsud's Avatar
namretsud namretsud is offline
Dodge Ram Forum Senior Member
 
Join Date: Mar 2012
Location: SW Ontario
Age: 60
Posts: 506
Gender: Male
Vehicle: 2007 1500 Mega Cab 4X4 3.73
Trim Level: SLT
Color: Inferno Red
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 4
Rep:185
namretsud has a spectacular aura aboutnamretsud has a spectacular aura about
Default

I would be curios about grounds and whether they used a heavy enough gage wire as to not overheat connections causing breakers to click off.
Reply With Quote
  #3  
Old 12-03-2013, 08:50 PM
511gtx69 511gtx69 is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2013
Location: 1000 islands ny
Age: 71
Posts: 27
Gender: Male
Vehicle: 2011 dodge ram
Trim Level: outdoor
Color: w/g
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
511gtx69 is on a distinguished road
Default

It's a new Western with a factory wiring harness. The strange thing is they say there are no brakers, just fuses.

thanks
Reply With Quote
  #4  
Old 12-16-2013, 08:46 PM
511gtx69 511gtx69 is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2013
Location: 1000 islands ny
Age: 71
Posts: 27
Gender: Male
Vehicle: 2011 dodge ram
Trim Level: outdoor
Color: w/g
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
511gtx69 is on a distinguished road
Default

We have snow again.

I'm still looking for defect.

help if you can.

thanks 511
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 03:23 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors