DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Powertrain > 5.7L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 12-12-2013, 06:18 PM
olchebby olchebby is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2013
Location: Charlotte, NC
Age: 42
Posts: 7
Gender: Male
Vehicle: 2006 Dodge Ram Quad cab
Trim Level: slt
Color: Atlantic Blue
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
olchebby is on a distinguished road
Default 06 issues p0306 missfire

06 hemi with 116k miles.
100k service, plugs (Iridium NGK), trans svc, etc.

About 2 months ago it threw a random p0300 (random misfire) out of the blue.
Couple of weeks later threw it again. No noticable running issue. Both times at startup.

3 weeks ago, leaving neighborhood, started popping and running very rough. Threw a p0306 (misfire #6). Pulled plugs and ground electrode was completely gone on one. Replaced plug, still rough running. New coil, same results. All plugs are tight. Was told it could be a valve spring broken. Endoscope looked like exhaust was hung open. Pulled rocker assy. no broken spring. Put all back together and ran perfectly.

few days later does the same thing. Turned off, reset code ran perfectly. Did it a time or 2 while driving, usually when cold or just starting out. If it does it out on the road, let off and drive easily and it runs normal the rest of the day.

Replaced PCV valve, then drove out of town, ran perfectly. 2 days later started it again.

Now I can't get it to run smoothly. Just checked plugs again and coil, all OK.

It has been suggested that it could be the MDS solenoid or a broken spring in a lifter ( problems he had seen before).

Any ideas?
Reply With Quote
Sponsored links
  #2  
Old 12-12-2013, 08:48 PM
dalboa dalboa is offline
Dodge Ram Forum Senior Member!
 
Join Date: Nov 2013
Location: Kansas
Age: 51
Posts: 75
Gender: Male
Vehicle: 2003 Ram 1500 4x4
Trim Level: SLT
Color: Black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:20
dalboa is on a distinguished road
Default

I've heard these hemi engines prefer the standard issue copper plus plugs. Nothing special, any idea what became of your missing electrode. Hope it didn't get stamped into a valve seat. I would take your injectors off and run cleaner through them. I took my intake off and with easy access to the injectors removed several at a time and hooked a hose to the top, hooked a wire from a 12volt car battery to alligator clip placed on one spade and the neg on another which I would tap to the remaining spade after putting a fair amount of injector cleaner into the hose. Worked great, could see the cleaner stream out with each touch of the neg to spade. Reinstalled and have had no problem with them. You might also be able to place a hose onto the injector body as the engine is running and see if you can verify that each one is working by listening to the other end of the hose. Sounds crazy but you'd be amazed.
__________________
If it aint broke, find out why!
Reply With Quote
  #3  
Old 12-12-2013, 10:07 PM
olchebby olchebby is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2013
Location: Charlotte, NC
Age: 42
Posts: 7
Gender: Male
Vehicle: 2006 Dodge Ram Quad cab
Trim Level: slt
Color: Atlantic Blue
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
olchebby is on a distinguished road
Default

Never saw the electrode. I was afraid it may have been crushed into the valve, but can't find any evidence of it.
Reply With Quote
  #4  
Old 12-12-2013, 10:36 PM
vtram vtram is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2011
Posts: 17
Gender: Male
Vehicle: 2010 ram 2500
Trim Level: st
Color: black
Rep Power: 0
Rep:10
vtram is on a distinguished road
Default

I was getting the same code. It ended up being the injector. After I replaced the plug and coil.
Reply With Quote
  #5  
Old 12-14-2013, 03:39 PM
olchebby olchebby is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2013
Location: Charlotte, NC
Age: 42
Posts: 7
Gender: Male
Vehicle: 2006 Dodge Ram Quad cab
Trim Level: slt
Color: Atlantic Blue
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
olchebby is on a distinguished road
Default

Put in a new injector, no change. Hearing a thud under the intake about every 3 seconds.
Reply With Quote
  #6  
Old 12-18-2013, 07:26 AM
olchebby olchebby is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2013
Location: Charlotte, NC
Age: 42
Posts: 7
Gender: Male
Vehicle: 2006 Dodge Ram Quad cab
Trim Level: slt
Color: Atlantic Blue
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
olchebby is on a distinguished road
Default

Pulled the intake and the runners were very dirty/ oily. #6 intake was dry/dirty where all others were wet and clean lower down where the injectors spray. Could the solenoid be bad for the MDS?
Reply With Quote
  #7  
Old 12-19-2013, 07:30 AM
olchebby olchebby is offline
Dodge Ram Forum Newcomer
 
Join Date: Jan 2013
Location: Charlotte, NC
Age: 42
Posts: 7
Gender: Male
Vehicle: 2006 Dodge Ram Quad cab
Trim Level: slt
Color: Atlantic Blue
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
olchebby is on a distinguished road
Default

Pulled the head and found a bad lifter on #6 intake. The internals of the lifter seemed to have spun and no longer line up with the hole in the side. Also #8 NGK Iridium plug has now lost it's electrode.....WTF?
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 11:14 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum