DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Mod Zone - Custom Dodge Ram Mods - Dodge Ram Performance > Custom Dodge Ram Performance Mods - Engine - 5.2 Liter V8


Notices

Custom Dodge Ram Performance Mods - Engine - 5.2 Liter V8 Discuss modifying your Dodge Ram with Performance Parts and Accessories!


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 12-31-2013, 11:54 PM
ChrisTM ChrisTM is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2012
Location: Middle of nowhere Illinois
Posts: 2
Gender: Male
Vehicle: 1998 Dodge Ram 1500 4x4 5.2L
Color: White
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:10
ChrisTM is on a distinguished road
Default P0720 after clearning throttle body?

Sorry if this is in the wrong spot I wasn't sure where to put it and this was my best guess.

Truck is 98 Ram 1500 4x4 with about 48k miles on it.

Long story short, my mothers POS trailblazer was having throttle body problems and it needed cleaning. I get the brilliant idea that since I am doing one, I might as well do mine while I am at it.

Immediately after I start the truck and move it out of my way and I get a CEL. I check it thinking I missed something and everything looks right, but I get code P0720.

I am comfortable replacing the sensor, but the rub is I got this code when I first installed the air intake. I don't believe it's the sensor but I could be wrong. Any thoughts?
Reply With Quote
Sponsored links
  #2  
Old 01-01-2014, 01:28 AM
ramvan2500's Avatar
ramvan2500 ramvan2500 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Apr 2011
Location: Florida USA
Posts: 1,903
Gender: Male
Vehicle: 1995 Dodge Ram B2500 Van
Trim Level: SLT - 2500
Color: Deep Molten Pearl Coat, Silver, Grey
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 4
Rep:128
ramvan2500 will become famous soon enoughramvan2500 will become famous soon enough
Default

Quote:
Originally Posted by ChrisTM View Post
Sorry if this is in the wrong spot I wasn't sure where to put it and this was my best guess.

Truck is 98 Ram 1500 4x4 with about 48k miles on it.

Long story short, my mothers POS trailblazer was having throttle body problems and it needed cleaning. I get the brilliant idea that since I am doing one, I might as well do mine while I am at it.

Immediately after I start the truck and move it out of my way and I get a CEL. I check it thinking I missed something and everything looks right, but I get code P0720.

I am comfortable replacing the sensor, but the rub is I got this code when I first installed the air intake. I don't believe it's the sensor but I could be wrong. Any thoughts?
I think one of the sensors you hit on the intake shares the same ground with the sensor for that code. Check to make sure you don't have any loose pins or anything. No reason a sensor should fail after throttle body cleaning. Unless...You used a non-sensor friendly cleaner.
Reply With Quote
  #3  
Old 01-03-2014, 02:19 AM
ChrisTM ChrisTM is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2012
Location: Middle of nowhere Illinois
Posts: 2
Gender: Male
Vehicle: 1998 Dodge Ram 1500 4x4 5.2L
Color: White
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:10
ChrisTM is on a distinguished road
Default

I think you're right, I didn't think about the ground sharing. Also I noticed I no longer have a grounding strap from my engine :/
Reply With Quote
  #4  
Old 01-03-2014, 02:26 AM
ramvan2500's Avatar
ramvan2500 ramvan2500 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Apr 2011
Location: Florida USA
Posts: 1,903
Gender: Male
Vehicle: 1995 Dodge Ram B2500 Van
Trim Level: SLT - 2500
Color: Deep Molten Pearl Coat, Silver, Grey
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 4
Rep:128
ramvan2500 will become famous soon enoughramvan2500 will become famous soon enough
Default

Quote:
Originally Posted by ChrisTM View Post
I think you're right, I didn't think about the ground sharing. Also I noticed I no longer have a grounding strap from my engine :/
Make sure you double check all your grounds. If the engine isn't grounded then it won't run properly. If at all.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 06:45 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum